Anyone image not appearing from Google drive etc..?

My app’s URL: http://obcc6.glideapp.io

As far as I can tell, your image on the front page shows, in fact, I can tell its a GIF file.

Without any more information from you, it will be a little hard to help you further.

You may go through on COD button. The is the list of images not appear and the rest images appear above

Still need to be more specific. I see a lot of items in the list with images and some that don’t. Is there a specific one that doesn’t work, but should, and do you have the URL for that image? It’s easier to focus on one thing instead of looking all over the app to try to figure out what’s wrong.

Ok here you may look into:

Problem not load image
I try to allow anyone to see in google drive but still same problem

Well, that’s an image and I can see it when I click on it and in one of the items in your app.

Hi all,

I’m having a similar problem

My app is app.pet-pardon.com Right now I’m populating the app two ways:

  1. From the back end….I take a picture of a dog from an IG post and then create a shareable link in G drive.

  2. From the front end, I allow users to add a dog (i.e. with image picker/uploader) which Glide then autogenerates.

A few days ago, I could add a dog from the back end. But the picture didn’t show there. However, it did show in the front end (i.e. the app). So no issues. As an aside, after waiting a few hours the picture eventually showed in the back end.

Today, when I tried adding a dog from the back end, the image doesn’t show on the back or front end.

As a test, I also tried uploading a dog (from the front end and the image doesn’t show on the back or front end.

Any insights are appreciated.

Thanks

Sheryl

What do you mean by back end? Which item in the app doesn’t have a working image? What’s the url for the image?

Hi Jeff,

Sorry by ‘back end’ I mean the google sheet the app references.

The dog name ‘Wilder’ didn’t have an image when trying to add him. However, when I clicked the dog to load the ‘details’ page/tile for the dog, the image showed there. But not on the main tile display.

In trying to rectify the problem, I added a row in my google sheet and copied the original row pertaining to the dog, pasted into the new row and published the new row and unpublished the old one. That worked.

I don’t know what the underlying issue is…

Here is the url for the image: https://drive.google.com/open?id=1ggFIp7pKfxWPgtO6e2m6cLdgYLE7KVga

Thank you

For all of my google drive images, I use a CONCAT/ARRAYFORMULA formula to populate a thumbnail link. Way more reliable in terms of Drive image links showing in your glide app. It’s likely because Google Drive has a lot of URL variations/ways to “copy” the shareable link to your image. So, I’ve found this formula works best to display as the image in Glide: =IFERROR(ARRAYFORMULA(CONCAT(CONCAT("https://drive.google.com/thumbnail?id=",(REGEXEXTRACT($B$2:$B,"([-\w]{25,})"))),"&sz=w960-h540")),)

Add a new column to your sheet, and replace $B$2:$B with whatever column has your Google Drive links! You can also change or remove that second CONCAT containing the size parameter at the end!

Interesting…I’ll have to try this @MegannLock! Regardless, it seems like something indeed is awry between Google and Glide if we have multiple users reporting the same issue. I have yet to test.

1 Like

Yeah I began encountering Google Drive image display issues about a year ago. It’s getting more and more finicky. I used to be able to grab an image share link from Drive for an image and use it in an array/image formula within a google sheet to display thumbnails in my spreadsheet (not even for Glide purposes). But now, it seems like those shareable links only work half the time. My theory is that is has something to do with the long as heck file IDs and Google Drive server issues.

1 Like

I bet you’re right. I’ve ceased using Google Drive altogether for photo storage…been using Cloudinary instead since then I can also manipulate and transform the images dynamically if needbe. I’ve been using for several months now and have yet to exceed 10% quota.

1 Like

:running_woman:t2: < me running to check out this Cloudinary lol

1 Like

Shameless plug…

Use this this link to learn how to use Cloudinary AND help me expand my credit quota :grin:

Try out the @cloudinary demo and see how you can manipulate your website images today!
https://cloudinary.com/invites/lpov9zyyucivvxsnalc5/no64tv2vwhmodhjalf4n?kind=twitter&t=demo

2 Likes

Here are my Cloudinary posts in case you’ve missed them:


1 Like

Thanks @MegannLock! I shall try this…I launched my app a couple of weeks ago and getting good traction. I’m populating it for now…but as I get more users I’ll need to have something more stable in place.

Thanks again!

1 Like

@MegannLock If it’s not too much to ask, could you give us examples of all the URL variations you’re seeing that don’t work in Glide as-is, and how you modify them to make them work? We’d love to support all of that out of the box.

Sure! I’ll comment here in a bit! To be honest, I haven’t found a pattern in which URLs work and which don’t. That’s why I am assuming it’s an issue on google’s end.

@Mark Here are all the Image link variations I’ve tried (and/or seen) and I usually had issues with in general— things like the image not displaying at all (whether it was in Google Sheets, or Glide, or even a webpage), or it would display the wrong image. I read a lot of conflicting info when I was trying to troubleshoot this about a year ago. Apparently, there are quotas for some of those types of image links. I found that using the file ID to create a link to a thumbnail view worked reliably.

http://drive.google.com/uc?export=view&id=fileID”

https://drive.google.com/file/d/fileID/view?usp=drivesdk”

https://drive.google.com/open?id=fileID”

https://drive.google.com/uc?id=fileID”

Here’s the formula I use for my google sheet to create a thumbnail link from any of those link variations above (extracts fileID and combines it with that thumbnail view link type! =IFERROR(ARRAYFORMULA(CONCAT(CONCAT("https://drive.google.com/thumbnail?id=",(REGEXEXTRACT($B$2:$B,"([-\w]{25,})"))),"&sz=w960-h540")),)

1 Like