🐛 Images Not Displaying in Tiles

My app’s URL: https://hoovertech.glideapp.io/

I have one image that is not displaying correctly in Glide as a Tile. I double-checked it and it’s correct in Sheets, but still not displaying the correct one. It’s pulling an image from a different app I’ve created.

The image I’m wanting to display is here, but the image that’s displaying is shown in the screenshot below that says “Google Forms”.

Here’s the link to the app the wrong image is being pulled from: https://hooverstaff.glideapp.io.

Here’s the image link for the wrongly displayed image.

Hi @spencerb,

Thanks for writing in. Happy to look into this for you. Would you be happy to send a screenshot of the respective columns in the Google Sheet?

Happy Saturday :slightly_smiling_face:

Tom

Here you go…

screen1

Thanks for the help, @iamtomgray.

My pleasure!

So, the misbehaving images—are they the ones linked to Google Drive or the ones that start “https://pbs.twim…”?

The misbehaving ones are both stored in Google Drive. For the thumbnail and title images for Seesaw and Flipgrid, I just copied the image address from their Twitter profile pages. But they’re not the ones that are misbehaving.

Forgive me, @spencerb, if you’ve already troubleshooted the following, but could you try downloading/re-uploading the image as a new file to Google Drive, and then link it to the respective cell(s)?

Ok, did what you suggested, and it’s no longer showing the image from the other app, but it’s not displaying the image either. I keep reloading the sheet in Glide, but nothing…

Forgot to mention that the image for these Tiles are being pulled from the Title Image column…

Are the sharing permissions configured correctly for that file, as per?: https://docs.glideapps.com/all/guides/quick-starts/getting-started/adding-images#google-drive

Yes, the folder is set to Anyone with the link can view, which causes all the images I’ve stored in this folder to inherit the permissions. Just checked it, and yes, the image is set to Anyone with the link can view.

For all of my google drive images, I use a CONCAT/ARRAYFORMULA formula to populate a thumbnail link. Way more reliable in terms of Drive image links showing in your glide app. It’s likely because Google Drive has a lot of URL variations/ways to “copy” the shareable link to your image. So, I’ve found this formula works best to display as the image in Glide: =IFERROR(ARRAYFORMULA(CONCAT(CONCAT("https://drive.google.com/thumbnail?id=",(REGEXEXTRACT($B$2:$B,"([-\w]{25,})"))),"&sz=w960-h540")),)

Add a new column to your sheet, and replace $B$2:$B with whatever column has your Google Drive links! You can also change or remove that second CONCAT containing the size parameter at the end!

1 Like

Can you please provide me with a URL to an image that is displaying wrong, the image you think it should be, the image you are seeing, and a link to the app where I can see this. This sounds like the caching layer has a different image than what you are expecting to see.

I just realized most of this is in the first post… sorry I missed that. Looking into it.

Ok thanks, @MegannLock. I’ll definitely consider doing this if for some reason we can’t get this to work. So weird that it’s literally one image that’s not working.

Ok, here is the image I’m wanting to display for Printing, which is underneath the Title Image column. It currently is displaying no image. In the first post, the issue was that an image from a different app I had created was displaying, but that’s no longer happening. So, current issue is that I can’t get it to display. I tried uploading an entirely different image a couple of times, but no dice. It just won’t display for some reason.

Should I try deleting the row in Sheets and then re-entering the image url to see if I can get it to display? @Jason, I guess I need to take off the password for this app so that you can view, right? Or no…

UPDATE: Deleting the row and re-entering the image url did not work.

I’m getting this error:

So weird… just pulled up the permissions and it’s set to Anyone with the link can view. Just saw in another thread that some other users are having this same issue?

printing-icon

Thanks to you, I already have a Cloudinary account. Maybe I should move all my assets there…

1 Like

Trying everything I can here: took off the 2 images I was pulling from those company’s Twitter profile pages, and instead downloaded those images, uploaded to that same folder in Google Drive, and pasted the links in Sheets, and now those 2 images aren’t displaying.

Pretty confident this isn’t the issue, but there wouldn’t be some kind of conflict if my folder in Google Drive is named Glide Images, is there?

UPDATE: Just downloaded the image from Slides (where I created it), and reuploaded a new image to this folder after Squooshing it, and it finally is displaying. Those other 2 images are displaying, too.

UPDATE #2: Still having issues with images displaying.

Any idea on why it would be misbehaving like this? Beginning to wonder if Google Drive is a good place to host images. Thanks for everyone’s help.

1 Like

I recently moved all my images to Firebase. Google Drive was acting strange.