Pictures do not display

My app’s URL:

I do not know but know each time I want to add a new pic with the URL from my Gdrive, the picture does not display
Does anybody experience the same issue?
Thanks a lot

Do you have a sample URL you can post? Are you using the shared link?

Also, drive isn’t the best for hosting images. Google will lock it down as “abuse” if accessed to often. You are better off using glide to host the images. You can simply drag and drop the image onto the image placeholder in the builder and it will automatically upload and populate the sheet with the proper url.

Thanks for your quick answer. below is the link I use :

It works with some pics and not with others, with no reason
I use a googl pro account, and I need some people access to the drive to contribute and add the pic. So it is the best way for us, so i prefer use Gdrive for now

So if you have any suggestion, feel free :slight_smile:

You need to share the image within google drive and obtain the shared public url. I can’t view the image because I don’t have access. It’s the same for Glide, so nobody will see any images in your app if they are not publicly shared.

It is very wierd, because it is what I did
I did shared the public URL and I do it for all my app.
I was using a public gmail, but I now I m using a pro one, it is the only change I see that can explain that

I don’t know what’s all different between public gmail and pro gmail, but as far as the url, I’m used to seeing “file/d/” are part of the middle of a public url.

I m wit the Google support
they have the same issue
they cannot see the image although it is a public
I will let you know !
Thanks anyway

1 Like

so now the glid bulder display the pic !
But when I go on the app from my phone, it does not display it :frowning:
any idea?

Ok, so Google find it
with a google pro account, by default you share with all people in your organisation, and not with everyone outside your organization

So you have to manually change the setting to anyone with the link (with the option Public)
So it is why it was working with a public google account and not anymore with a pro account

Thanks for your help