Images don't show on the app

Hi.
I am trying the Glideapp, which I find very easy to use.
However, I cannot figure out why my images (which I saved on my Google Drive) don’t show on the app (only on my browser app, but not on someone else’s browser).
This happens to me also when I try to add a signature image to my email body in my Google email account (in that case I also store the images in Google Drive).
Any idea?
Thank you in advance.

Have you publicly shared the image and are you using the sharing url in the sheet?

https://docs.glideapps.com/all/guides/quick-starts/getting-started/adding-images#google-drive

1 Like

Yes I did. I followed these steps as indicated:

  • Open Share settings for the image.
  • Make sure Anyone with the link can view the file.
  • Copy the link.
  • Paste it into your sheet

Do you have any suggestion as to what might have gone wrong?

Can you check if the default for your links are https:// or http://

It happens to me very often.
I ended up moving all images to Firebase, and problem solved.

1 Like

Hi Thinh,
They are https://

Hi Eltintero.
Thank you for your suggestion. I will try to solve Google Drive as I’d like to keep everything in the Google products (I pay storage to get the services, which usually work well), and if I can’t find a solution I will check out Firebase. Is this what you are talking about? https://firebase.google.com/

Yes! It’s a Google product as well.

Jesus A.

Hello. Google Drive works. I thought I had chosen “anybody can see link” but I was on my corporate account, and had to click one more time to choose “anyone…”.
I will look into FIrebase. Looks like it’s the goto place for someone who is venturing into apps, like me.

1 Like

Good to hear Laura, try Firebase and if you have any problems feel free to ask us here.