Recurring Sync Error

Hi there I have a GlideApp that I’ve been building for awhile now, and for some reason when I shifted my google sheets over to this new sheet everything linked and has been working for months, but there is a recurring sync issue.

Every so often the data won’t sync, and on the sync page it will show the yellow hazard sync and when I click it it shows a huge amount of “columns missing” and the red remove and resync. After pressing it and resyncing over time it will update, then after some time re-popup with that specific error or this other one specific error.

Screenshot 2023-07-22 at 4.10.34 PM

Then for some time it will sync (about a day) then run through the same cycle. This error has been showing for weeks now and I sent a support message to Glide but have not received a response…And I’m on the $99 Pro Team plan if that helps.

The issue with this small bug is to have to constantly manually refresh my data almost daily.

Will someone please give a hand to help fix this? :slight_smile:

Thank you for your help and support! Your platform is AMAZING!!!

Do you have a google sheet tab that is built dynamically from a formula?


Hi Jeff, Initially yes I did, within my google sheets file I had a sheet named “MKPIs” that was pulling data from another sheet’s MKPIs section using the IMPORTRANGE() function, then I eventually decided to combine the google sheet files, and when I cloned over the new MKPIs from the older google sheet, renamed it, and deleted the old sheet, the data grid in my app that was linked to the columns for the imported data (from the importrange function) happened to link correctly in the new data grid so I didn’t change it. Maybe this is the source of the issue ?

What would you recommend in this situation? :slight_smile:

The whole reason I asked if you used a formula to build a table is because, if the first row of headers is also imported as part of the IMPORTRANGE, then you can run into issues because there is a chance that the formula may be recalculating at the same moment that Glide is syncing the data. If that happens, then there is a short moment where the table doesn’t have any headers and can break the sync. If you ever use an IMPORTRANGE, it’s always good practice to have static headers in the first row, and start your import on row 2 while setting up the import to ignore the headers from the table it is pulling from.

So currently you don’t have any tables built from a formula?

Do you still have a table named MKPIS, or is it named something else now?

1 Like

Wow that’s a great point! I had it importing over that first row and then I shifted over the sheets so maybe that is the issue. I have a sheet titled MKPIs but no first row importrange because the values are static instead of importing from another sheet.

I removed the data grid headers that are linking to the error rows and will wait to see what happens! :slight_smile:

I appreciate your help Jeff!

HI there @Jeff_Hager I still seem to have the issue…I tried renaming my sheet by appending NEW to it then sync, and it simply syncs the new sheet and keeps the old error. Is there a way to find what parts of my app are using those specific columns? Even when I click for the columns to be removed they are still showing up.

Does Glide have a 1 on 1 teamviewer-style technical support ?

Try making a duplicate of your Google sheet. Then go to your app → settings → Data → Replace the current Google sheet with new spreadsheet.

Works for me most of the times.


Yeah, try @Hassan_Nadeem’s idea. If that doesn’t work, then you can try duplicating the app and monitor the duplicate app to see if you have the same issue.

I’m not really sure what’s going on here. Seems like you did what you needed to do to resolve the original issue by merging everything into the same worksheet with static headers. My only thought is that there is a back end bug somewhere that’s holding on to the original sheet for some reason.

If you still have issues, you may have to submit a ticket to support.


Here’s how to open a support ticket, just in case.


Thank you all for your help and support, @Marcel (not sure which Glide username he is) suggested I had too many columns (over 500) and so what I did was remove columns and also some of my columns had duplicate headers which may have been an issue, this seems to have fixed it! I appreciate you all!