Google Sheets stopped syncing? Let us know!

Hello Gliders!

We’re seeing an increase in forum posts about Google Sheets sync issues.

So far it seems to affect legacy apps with existing Sheets connections, where the automatic syncs started misbehaving about two weeks ago.

We want to get all of these tracked in one thread to help our engineers troubleshoot.

Please add your details to this thread if:

  • You have an existing app with an existing Google Sheets sync
  • Your sync was working fine until recently

Reply with your Team ID and affected App ID, a description of what you’re experiencing, and when you started experiencing it.

Your Team ID is in the URL of your Glide dashboard, e.g.

Your App ID is in the URL of the Glide builder, e.g.

Note: Any replies unrelated to the Sheets sync issue will be removed.

If you have general questions or need help about Google Sheets as a data source, please bring those to the Ask for Help category.

Thank you! :pray:


This may or may not be related, I’m not sure.

Team ID: x8Cvdv8CAlJthHXWJpUP
App ID: ffE13kxupmsatyOXR4wu

  • Context: App has a mix of Google Sheets and native tables. The Users table is a Google Sheet. App is about 18 months old, private. New users are added via the Glide UI.
  • Symptoms: When new users are added via the player, they immediately appear in the Google Sheet, but not in the Data Editor, nor are they visible to any other player clients. After some time - typically about 15 minutes - they will appear in both. A forced manual sync from the Data Editor causes the new row to appear immediately.
  • How long has it been happening: About 2-3 weeks. Prior to that, new rows would appear almost immediately.

I guess I’ve seen delays too, but it hasn’t been mission critical for me yet. In my case, I knew exactly when some data was added by the user. Even a manual refresh in the data editor wouldn’t bring the new data into the builder, or allow it to show in the app in right away. Probably took 10-15 minutes.

I have a weird setup. I have an old MyApps Legacy app that I’m still waiting to get migrated. I think I noticed the issue in that app. I also have a New App (which is a rewrite of the old app in a Starter plan and will eventually replace the old app) connected to the same Google sheet in a different team folder. I don’t think that app was immediately syncing the newly added rows either, but it’s well over the row limit, so not totally unexpected…although the particular table I need has been loading in it’s entirety for me in the new app.

I have a third app in the same starter plan team which is supposed to pull data from the same Google sheet, but I don’t have the sheet connected at this time and I have to manually copy and paste data because there is an outstanding bug where Glide is improperly counting data usage and puts me over the data usage limit by counting the exact same files multiple times if they are referenced in multiple apps. The only reason I noticed this delay issue is because every time the user uploads new files and adds new rows to the table, I have to do this manually copy process and lately I’ve had to wait several minutes before I can manually copy the data.

Bringing this over from the other thread I started… I am seeing ARRAYFORMULAs no longer working - only the first row where the formula is located is syncing over to Glide, the other rows all appear blank.

I first noticed the issue this morning (3/1) but not really sure exactly when it could have started.

Team ID: dzOTuFSjeNjyZuZBUiEs
App ID: YV3vT2Ddds9CMvqKmhpx

I have 2 apps that stopped syncing with GSheets since mid January

Team : sCEb0Si83lKpVIOM3yQi
App : w4HHUTrA2k9dBcd0Yvta

Team : kIh9CmzsyeBGss7CSvl3

I have one app that experienced occasional syncing issues with Google Sheets where we’d see a row in Glide, but not in GS. There’s a live support ticket open on this, and we haven’t heard a response.

Team: 8ZVPAu7mSQ4MzF0V5QvR
App: FmxURaj490B9iDkU8Dxb

Team: POGlcTMDiz2bRcfg3jbP
App 1: fMFJ5fTXJbjgZG0WrJQG (started as google sheets app)
App 2: EkTnPk498SaR0jf0aVZt (glide tables app)

I first noticed it on App 1 that was connected to google sheets — it stopped syncing and then I couldn’t reconnect. I also tried creating a new app off it and that doesn’t work. Then I went to change app 2 from a glide tables app to a google sheets app and I cannot connect either.

What happens is in all cases, I get the google auth prompt and I login with my same google account that I’m signed into glide with, and the same google account that has the sheets I want to connect to. However, after the auth window, it just closes and I never get the option to select a spread sheet, or move any further, the page is just done loading and nothing happens.

Thank you for looking into this!

Update: We pushed a fix last week to address the issue where new rows added to a Glide app conflicted with the Google Sheets data source.

@Evgeny1 - I think it addresses what you’re describing here? Are you still seeing the issue with the app data not showing up in Sheets?

As for some of the other posts…

@Nate_H - Are you still seeing this?

@Darren_Murphy - Are you on the new player preview?

@xzab - Sounds like a potential cookie/cache issue. If you’re still seeing this, try authenticating in with another browser or incognito mode (if you’re using Chrome).

1 Like

Yes I am.
I haven’t had any reports from my users about this issue in the past few days, but I did tell them if it happens they should just wait a while, so maybe they are getting used to it. I’ll try and get confirmation if it is still happening or not and report back.

1 Like


If your users are still seeing this happen, grabbing a session makes is a lot easier for the engineers to dig into what’s happening.

I have the issue with multiple delete (through relations). These are some of the strange behaviors that I have observed randomly:

  • Related rows appear to be deleted in Glide, but as the syncing with Gsheet is not done, they reappear later.
  • Only one of the multiple relations is deleted/synced with Gsheet (usually the last related record)
  • Despite the action, from which one of the steps is a multiple delete, is going through all the steps (I set up notifications to verify this), it does not appear in the run history of the custom action

Team: fRsZXkQawcbhlsffooch
App1: Ve7H81X6ZRN7VvMZRH2O
App2: HeCPNyKCfVdkF5V7fnld

Checked with my users today, and they inform me that the issue appears to be resolved :+1:

Team ID: Glide
App ID: Glide

I uploaded the data into the glide through google sheet and then I made a changes into the tables in google sheet but when I opened glide and refreshes several time there were no changes updated in the data editor tables in glide. Please fix it as soon as possible. I’m stuck here with the project which I need to complete as soon as possible and I can’t again write all the data into the glide data editor table. Both the google sheets and glide data editor are not in sync and it’s creating trouble and inconvenience.

Thank you for letting us know.

From our side, so far, everything seems to be working fine. The previous sync issues didn’t re-surface.

Equally, we’re re-building some of our features in Glide tables (except the Users table). Once your Make integration goes live, we will say good bye to Google Sheets entirely and will write straight to Glide Tables.


Just a note for Endy - according to the other topic (I've edited the data in my google sheets but the table in glide is not getting updated with the changes in google sheet - #7 by Darren_Murphy) Vivency is on the New Free Plan and her GS is not connected to her app but only used as an import template for a Glide table. Therefore there is no sync to be expected.


Tried Chrome / Brave / Safari, all in and out of incognito mode, and cleared cache and cookies on each. Same issue every time — just auth window disappearing after authenticating.

Okay, thanks a lot for letting know.

Okay, thank you so much.

I’m still having issues of not refreshing:
team ID: Glide
app ID: Glide

its a very simple app on the free plan, and I am not at any limits at the moment.
It is for my autistic son. It does 2 main things:

  1. Reads from a big table of his school activities and displays the ones tagged with the current day of the week
  2. provides a getting ready checklist. As he checks them off, it stores the completion in the sheet. It then resets every night using a script.

It also shows the weather, and a joke of the day. Again these are generated using a script in the sheet rather than anything in the app

The issue is: glide is not updating to the latest data in gsheets (after gsheet updates via script)

I tried switching to a different data source, but no luck there.