Google sheet, sync, edit, restore column in google

well, i hope that someone responsible see this topic.
in some cases it’s a continue other one: Too much google sync - #19 by user19
but not the same.

in case of looking for eliminate syncs that should not be, i made some steps and going to share it with you.

  1. i delete one tab in google sheet. glide say, that now it’s not possible to sync glide sheet with google, but app still functionality. i don’t make a new data on google side.
    behavior of updates - changed.
    before if user add a row to that table - also appear about same quantity of sync. David say, that updates don’t count twice, and if we add a row - it’s counted only as add and edit (form and action).
    so, after i remove a tab in google - sync stop appear. I’m happy!!! but just for a day.

each time, when user fill the form that add a row - in updates add counted. but in glide sheet information not appear (row not added).
hey! why so? why counted add if no new row added??

what is the logic of sheets?

  1. google sheet is a main sheet and all data from app saved to it.
    this give explain why after remove tab in google sheet - new row don’t appear and stop counted sync. But it’s does not explain why add and edit still counted.

  2. workflow of data is like this sequence: app - glide sheet 1 - google sheet - glide sheet 2 and wise versa.
    so, if google sheet not deleted we have same time add/edit update to sheet 1 and sync to sheet 2.
    and if we delete a google sheet - we don’t have a sync, but we have add/edit update and don’t see actual/new data in app.

so, whole day user add new data and sure that it’s stored. but no. it’s not.

  1. so, i decide to “restore these columns” as glide say. and move that tab back to google sheet. but glide still don’t see it.

  2. i try replace google base - no result. in base that tab with column exist (same name) but glide don’t see it.

  3. finally, i restore a google sheet with version where tab was exist (i know that sheet have personal worm, as i know tab don’t have it but… have to try all way).
    it doesn’t help: glide say “These columns are missing:” and i can’t sync data manually.

Glide does not work as written in manual. please do something with it. it’s not predictable behavior - not possible make a complicated projects…

last thing that i have - help me to restore functionality:

google sheet that i use before, and where i restore a tab - save in google with different name, and then replace in data source.

well… i guess now again will appear sync from nowhere.

First of all, you are brave for removing a sheet just to test this. I would have done it with a copy of the app and sheet to not cause any issues with the original. I still don’t have an answer as to why you have extra update counts. I suspect that there is is something happening in glide or in your google sheet that you are missing. I feel like something is causing google to send data back to glide. If Dave is correct that Add/Edit does not also count a Sync, then the only thing I can think of is that something in the google sheet is causing it to send data to glide…even if it’s the same data. Anyway, here is my understanding of what you are seeing.

The app will still function because glide has a copy of the google sheet data. When you use your app, there are 3 copies of the data. The Google Sheet copy, the Glide Server copy, and the copy on the user’s device. When you make a change in the app, it first syncs to the glide server, and from there is syncs to the google sheet. If there are any changes in the google sheet, then it syncs back to the glide server, and from there it syncs to the user’s device. Since you effectively broke the link between the glide server and the google sheet, glide is no longer able to get updated data from the google sheet…meaning it can’t sync.

Glide’s copy of the data probably locks up because it can’t communicate with google, so it keeps reverting back to what the data looked like before the connection to google was broken. However, the app is probably still triggering the Add/Edit counts. This is obviously not a normal situation as you wouldn’t normally have a broken connection between glide and google.

I think I covered this above. You are still attempting to Add/Edit data, so it’s still counting those updates, but since glide can’t communicate with google, a sync never occurs. The glide server copy of the data is frozen.

Yes, you have to workflow correct, but the glide version and the google version of the data aren’t updated at the exact same time. The glide server copy gets updated first, and then glide sends that update to the google sheet. And again, the connection is broke, so the glide version of the data does not get updated. This is probably because it wouldn’t know what to do if the connection was restored.

Even though the name is the same, the underlying ID that google assigns to each sheet tab and the entire google sheet may have changed when you restored the tab. Technically, if you did try to replace the entire google base through the project settings, then in theory it should work. I’ve never attempted it myself, but it should have worked. Maybe it didn’t because you already had a broken connection between glide and google. If you then clicked on “restore these columns” then maybe it would have worked, but I’m not sure.

Yes, this is the safest way to do it because the underlying sheet and sheet tab ID’s would remain the same. At this point, I think your only option is to click on the button to restore columns. The message is misleading sometimes. It past tests, it has still worked for me without losing any functionality. BUT, before doing anything, I would suggest making a duplicate copy of your app. Both with the Same Sheet, and with a Copy of the Sheet. This is just in case some functionality gets messed up when you click on the restore button. You at least want to have a backup to refer to.


Not that much. i didn’t remove a whole sheet on work project. i did it first on copy, and didn’t see a screen “you don’t have app anymore”. so i remove just one table from work project, that i suspect in addition sync.

i download google sheet as exel file, make search for “=” - it will show all cell with it and all cell where it us as formula. so as expected i found no one formula.

  • Sometimes Glide will sync your data source and find that no data has changed. In this event, the Sync is not counted (you are not charged for Syncs that don’t provide new data).

so if even appear sync of data that didn’t changed - it should not be counted.

please more info from this moment.
it’s looks not exactly…
i remove google sheet in data source - and all glide base structure - also disappear. i expect that it just will be no more link with google, but all structure keep. no. blank base.

i don’t see such behavior: user make changes in app - glide count add/edit - but glide server copy new data don’t appear. new data was generated not on google, but on app.

but you cant be sure in it. right? all the time was explained by glide, that we have 2 way data flow: from glide to google and from google to glide.
app generate a data, and put it to glide, but glide cant send it to google. why it’s mean that new data must be deleted?

i don’t have such button. where is it?

I can’t explain it. Just offering my thoughts. That’s a question for Glide to answer.

When you add a google sheet to a project, those table are inherently linked and rely on an attached google sheet. A copy of the data is still stored on Glide servers, but it’s still very much a part of the google sheet. You can’t just remove a google sheet tab and expect Glide to take over with it’s copy. It still need that google sheet tab to exist.

I think we are explaining the same thing. The new data doesn’t show up in glide’s copy of the table because it’s connection to the google sheet tab is broke. It doesn’t know what to do. Like I said above, Glide’s copy may still be there, but it’s trying to reconnect to it’s underlying google sheet. If it’s not there, it’s broke and you should be seeing a warning that it can’t sync with the google sheet due to missing columns.

No, I’m not completely sure, but I also try not to put my app into a broken state by removing a google sheet or a google sheet tab that is still being used by the app. Breaking that connection is not normal and most likely explains why data isn’t saved into Glide’s copy of the data.

You mentioned a restore button in your previous post. I’m referring to a message that looks like this. If your google sheet was restored to how it was before, It’s usually safe to click this button to get restore the connection between Glide and Google. If you are confident that all columns are there, then it should work without breaking anything in you app that may have used those columns.

(This is an old image, so the warning may have changed a little bit)

1 Like

i be glad to have same option, but i have extra sync, that make my app not working. support didn’t give an answer about reason. at least i ask about data - what exactly was synced? still no answer. all this situation about a month. i have to do something. a lot of things in glide resolved not by remove bug, but through find a way to avoid it. i try.

it’s not working like you say.
i restore a table by 2 different way. last of it was a restore previous version in google - so table was a right it was before. but glide don’t recognize it.
usually, if in google disappear a column - glide say that cant sync data. if make new column with same name as before, or restore previous version - glide find it in real time and stop saying about problem. but it not worked with table. it’s a bug. but i don’t want that glide fix it. it’s better spend time to make migration…