Glide cannot sync with your Google Sheet

Glide cannot sync with your Google Sheet

These columns are missing:

To resume syncing, restore these columns or remove the features from your app that use them.

Cancel

Remove Features & Sync

How should I work around this? I don’t understand what the problem is … I tried to Remove and Sync features but it still doesn’t reload the sheet and sync it. I tried fixing two of those columns in the sheet but it still pops up showing there is a problem with this column

Did you make major changes to you sheet that affect columns that are being used in your app by other computed columns or components? So you’ve clicked on the button to remove features and you still get the same message?

This usually happens if glide can’t find a column in the data, but other columns or components are still referring to it, so it can’t properly sync and wants to remove any component, action, or computed column that may be using that missing column.

Yes I did click Remove and Sync and the problem still persists. Also I really don’t have values or sub-sheets that are referenced to this for my glide app. Like I do not use them in any calculation of sort as of now except the Copy sheets… So why is it still showing the problem?

Hmm, unless something else is just out of sync. You could try duplicating the app to see if the duplicate gives you the same problem. Otherwise, I’m not really sure what could be happening.

You could try making a video of the issue and posting it here or submitting it to glide support.

https://glide-help.zendesk.com/hc/en-us/requests/new

I am unable to create any new app with that sheet as well. If I use some other sheet it seems to work just fine. So I think the problem is with the sheet. However , I am trying to duplicate the sheets on another spreadsheet and check if it works. Further, I am already in touch with the glide support team as well relating to the new app creating problem. Thanks for your input!

1 Like

Jeff, I’m beginning to see this error also. However, my sheet is HUGE. I have users enter data in forms and then that info gets spread all over the place. It would be useful if the error message actually gave more information about the columns that it thinks it needs to remove. That way I could hunt it down. Instead it seems to give me a long alpha numeric name of a column that I can’t find. Can we enhance the error reporting in glide?

1 Like

I would suggest sending a bug report to glide using the link above. I’m just a fellow user, so I can’t help with system bugs or making the error messages more informative.

If I were to simply guess, I’d say that maybe a column was partially created in the past, but not completely, used for something, and then deleted, but glide is still looking for it…but I have no idea what it could be.

2 Likes

This has just happened to me too, but I see the issue - maybe this is the case for others? I have two rows of instructions in my Google sheet, with the 3rd row being the actual column headers. For a long time I had just one row of instructions, and then several months ago I found it necessary to add a 2nd row. I was worried this would throw off Glide, so I went back & forth between browser windows to make sure Glide was okay with having my columns begin on row 3. At the time, it was, and everything was fine. Starting sometime in the past 72 hours Glide is no longer fine with this set-up. The data editor shows most of my Google Sheet columns as being “column1, column2, column3 etc…” and my first row of “data” is now the 2nd row of my sheet instructions. The app is still working but I’m getting the “Glide cannot sync” error. So seems that going forward Glide will only tolerate one row being ahead of the column header row :confused:

ETA: I’ve just changed my sheet to only have one instruction row (column headers on row 2) but now Glide is refusing to sync the changes. This is now a big problem. I can’t “remove features & sync” as that would basically remove almost my entire app! :sob:

CleanShot 2021-11-02 at 02.12.57

Why do you have your column headers on row 2 or row 3 though?

Did you happen to unfreeze your header rows or change the number of rows that were frozen? As far as I know, glide would only possibly allow a setup like yours if the header rows were frozen, but I’m not completely sure. I always reserve the first row for headers. I have reserved the second row for formulas in the past, but that second row can usually be set up to be ignored by glide. I always treat the sheet as a database, so I don’t put in anything that shouldn’t be interpreted or doesnt serve the purpose as data or help in calculating the data.

2 Likes

@ThinhDinh my source sheet is shared with others and requires a couple lines of instructions at the top :confused:

@Jeff_Hager I did not - there’s the small chance that someone else played with the freezing but it’s super unlikely (and I went back through several versions to make sure I wasn’t missing something)

The data on that particular sheet is set so that Glide only uses rows that have a particular value in one of the columns - so maybe that previously helped in ignoring the non-data rows?

The issue now is that Glide is refusing to sync even after I fixed the Google Sheet. Should I change the column names from inside Glide, even though the Glide sheet doesn’t currently match the Google sheet? (I’m a bit terrified of everything breaking beyond repair now)

If I can get this sorted I will duplicate the header rows at the very top of my Google sheet and set them to the same background color as my instructions row - meaning there will be two rows of column headers - one hidden in the very first row that Glide can use, and another two rows down that sheet users can see.

But I’m pretty sure I was getting away with a bad practice for a year that Glide WAS handling, but a change was made to no longer tolerate :face_with_monocle:

I think you can add a note at the top cells so people can read your instructions. I’m all for keeping the database clean as Jeff said.

1 Like

Have you tried duplicating the app?

I have in the past seen a situation where Glide refuses to sync, but if you make a duplicate of the app (keeping the same Google Sheets) then the duplicate is able to sync normally.

1 Like

Have you tried removing the instructions, at least temporarily, so the headers become the first row…then try to sync?

If that works, then I think it would be safer to put the instructions on rows 2 and 3 after the headers.

1 Like

@Darren_Murphy yup I tried that last night - same exact issue with the copy :frowning:

@Jeff_Hager yes I just tried this, no-go. I then tried restoring the Google sheet to its exact state before the syncing stopped, this also did not fix things. THEN I tried changing the name of the first column back to “First Name” from inside Glide - but got the same pop-up that “First Name” is missing. The weirdest part is that the pop-up is immediate - there is no indication that Glide is even trying to sync the Google Sheet before throwing the error. Also - the Glide Sheet IS syncing back to the Google Sheet - as soon as I changed “column1” to “First Name” the first cell in my Google Sheet changed to “First Name” - so the syncing is only happening in a one-way direction.

ALSO (sorry for all the alsos) I just now noticed as I scrolled sideways across my data editor that Glide did in fact just update their data editor. All my non-basic columns are now a lovely shade of turquoise and they were not like that yesterday. If this was rolled out yesterday then I’m really suspecting the issue is with the new data editor.

1 Like

In my past experience, I’ve found that it’s really hard to initiate a sync on the glide side if something doesn’t match up, or if glide thinks that something doesn’t match up. It seems like it gets an error, and then never tries again to recheck the google sheet to make sure the column is actually missing. For example, I used to have a sheet that was filled entirely from a formula (including the headers). Sometimes glide would resync while the sheet was refilling and temporarily empty. This caused me to get the same error as you. Clicking the refresh button in glide would never help and would issue the warning immediately (didn’t seem like it even tried to check the sheet). I had eventually found that if I just waited a few (or several) minutes, and maybe made a data change in the google sheet or through the glide data editor, then eventually everything would reconnect and then it would resolve itself.

I would at least try moving your headers to the first row in the google sheet. I firmly believe that they need to be in the first row no matter what. Then just let everything sit untouched for maybe a half hour to an hour. Then see if it reconnects the columns.

4 Likes

Dear Glide Sync,
Giving up the first time you fail is not a way to go through life!
Sincerely,
Glide Developers :yellow_heart:

Jeff this is so good (and validating) to know - I did exactly that but I only waited a minute or two before throwing my hands in the air and reverting the sheet back. I will try changing headers to the first row again and this time leaving it for at least an hour (and will poke it with some meaningless data changes on both sides) I’ll even try verbalizing some compliments & encouragements :crazy_face:

Thank you, fingers crossed! :crossed_fingers:t2:

2 Likes

Fixed! Fixed! Fixed! Takeaways:

Letting it sit for an hour didn’t help - I finally clicked “Remove Features & Sync” and this fixed :sparkles: everything :sparkles:

But before I resorted to this white-knuckle step I did several tests on copies of my app:

  1. Copied app & sheet, deleted a couple columns from the sheet, waited for the app to throw a sync error, than clicked “Remove Features & Sync” - this deleted all the columns and components from Glide as expected.

  2. Copied app & sheet, deleted a couple columns from the sheet, waited for the app to throw a sync error, then UNDID the deletion of those columns in the sheet, clicked “Remove Features & Sync” - this forced the sync, cleared the warning, and nothing was deleted.

  3. Copied app & sheet, deleted a couple columns from the sheet, waited for the app to throw a sync error, then undid the deletion of those columns in the sheet, then ALSO added several (3!) header rows above the column names. Then clicked “Remove Features & Sync” - this forced the sync, cleared the warning, and still nothing was deleted :grinning:

So by the time I pulled trigger on my real app, I felt 98% sure I wasn’t going to lose anything. I also realized my header rows were never part of the problem! I mean they were a problem in that suddenly yesterday they were appearing in my data editor and throwing my column names off, but they were not the cause of the syncing issues. I realized that Glide was only ever telling me that “First Row” was missing. I also suddenly remembered that the first back-up copy I made when things started getting weird yesterday WAS missing all the data from the First Row column - despite all that data being intact in the original app & sheet and even on the copied sheet. I had never ever deleted that column, I think though that there was a hiccup where Glide couldn’t see it for a second, and it just never recovered. I still suspect this is related to the changes made to the data editor that day - maybe right as I was working in it. Once my app was happy again I made sure to change my first sheet row to the header row - even if Glide can technically still handle it, those instructional rows suddenly appearing in the data editor were definitely foreshadowing future problems. Plus everyone’s “don’t do that!” advice :+1:t2:

Most important thing I learned from my test cases: that sync error pop-up is totally misleading! The pop-up indicates that you can restore the missing columns OR remove the features that use them. Then the red button only states “Remove Features & Sync” which anyone would assume means “Only press this button if you chose the 2nd option of removing the features.” In fact, this button needs to be pressed in both instances. Once columns have been restored pressing the button just forces the sync and clears the error, all data remains intact as long as the missing columns are now present. As @Jeff_Hager and I both experienced, Glide does not want to re-sync on its own once a sync error has occurred. So now I’m thinking that’s intentional behavior and the pop-up instructions are just misleading :thinking:

I also learned that no matter how many columns get deleted from your sheet - resulting in a sync error - that pop-up warning will only list the first four missing columns :woman_shrugging:t2:

Hope this helps someone else down the line - really really appreciate all the input! Helps me get to the solution :star_struck:

8 Likes

Nice catch. :+1: I’d never noticed that.

4 Likes

That’s awesome! Glad you got it working again, and thanks for the write-up on your experience! I wouldn’t have ever guessed that pressing the button attempts a sync before removing anything. It seems like it should be doing that before even showing the warning message. I know I’ve always been extremely nervous anytime I’ve seen that message…especially on heavily used sheets where it would be a nightmare to recreate some of the logic.

3 Likes