'My Profile' > 'Edit' Form doesn't save field changes consistently

Team ID:
https://go.glideapps.com/o/jlc6di4cMNXe1xL75U1Z

App ID:
https://go.glideapps.com/app/4DtWHPLwEBzVjnJI5fKs/layout

Description
Going to the default ‘My Profile’ page in my app, and clicking on a default ‘Edit’ button opens a configured edit form for our users table. Making changes on this form is saving inconsistently; I’ve noted about 5 fields that do not save changes in the UI. For example the ‘First Name’ field does not save, but ‘Last Name’ does, despite being configured exactly the same.

We are using an Airtable database and this was not occurring previously. If I create a custom form to edit these fields it works, but it’s an annoying workaround that we can’t use the standard Edit form due to this bug. No other tables are having this issue.

I have tried:

  • Reconnecting the data source
  • Duplicating the app and testing that
  • Testing data sources; updates do save if made in Airtable or Glide Data tab (just not the UI)
  • Simplifying the source table (less fields and formulas)
  • Testing in Incognito mode, other browsers, on a mobile device, with different profiles

How to replicate
Login to app. Open default ‘My Profile’. Click ‘Edit’ button. Make changes in form. Some changes (including First Name) don’t save.


I found some articles mentioning a similar issue but found no clear solutions (that have worked). Any help would be greatly appreciated!

Please submit a ticket. Thank you.

We are on a Non-profit plan, which apparently doesn’t include Glide support. Anything else I can try?