Edit screen/form not saving data consistently

Hello,

My basic users’ profiles are created and edited from Show Edit Screen button that takes you to Edit Form screen. When I edit data on my profile and then select done, the profile is successfully updated. However other users have been reporting that after tapping done, the changes they made don’t update their profile successfully, and they loose those edits. Now I see that of the last 10 or so users to have created a profile, it only saved the data for 1 of them.

This is an app with over 1300 profiles previously made with this edit screen, so I’m at a loss as to why Glide isn’t saving the data correctly.

Help please!

My App/Pages Support link:
https://go.glideapps.com/support/fe55b4fa-7a62-4a0e-bc0a-a1d3eab19519

Describe the bug:
Edit Form not saving.

Expected Behaviour:
When selecting “Done” the new data should be saved.

How to replicate:
When I try, it works. When others try, they often don’t have their data saved. This is known because the “done” button requires certain fields to be completed in order to tap done, and the action also marks a “profile complete” column true. I’m seeing new users with profiles marked complete, but most the the fields are blank. Users are also confirming that they filled it out, hit done, and it doesn’t save.

So you can’t reproduce it yourself, but your users can? Do you have a video from any of them?

Yes, yes, and no. But I can see what’s going on based on other indicators besides what they’re reporting. A “profile setup” column gets marked true when selecting done. Done is only clickable when the required fields are filled in. Yet the required fields are empty for many of the new users (who some of them have also reported to me that this happened.)

Is that screen filtered, or are you using row owners?

This is using a row owners sheet.

You can try it out if you want to see if it happens for you, or if you find anything. app.milspocial.com. Just put dummy data or “glide testing” for all the fields. You set up account and that part works (using a “Details” screen) and then it prompts you to create profile, which is an Edit Form screen… both data being saved to the same sheet, but for the user I have fields separated into account info and profile.

Of the last 10 or so accounts to have been created, only 2 of them saved the data correctly.

I just gave it a go, although it’s difficult to tell if it saved correctly.

One thing I did notice is that after finishing I viewed my profile, and I could see that some data I’d entered wasn’t shown. But again, I have no way of telling what should and should not be visible.

Anyway, there was nothing that stood out that might have provided a clue as to what might be going wrong.

Thanks for testing it out Darren. I see you profile is marked complete, but the info is mostly blank still, as is the problem for most new users. When you click on the second tab, your profile, you should see a standard looking profile not just your name and playlist. You can try editing your profile with the pencil icon at the top, and you’ll see the info that you presumably filled out before selecting done the first time, is gone. If you repeatedly type stuff in and hit done… maybe it saves sometimes, maybe it doesn’t? Idk. For me, it saves. For some other people like yourself, it doesn’t. And I don’t know why.

Actually, no.
I did try that, and everything I’d entered was present in the edit form. Just not all of it was shown on my profile.

It might be worth going through those few screens in detail, checking everything - all component settings, visibility settings, etc. There have been lots of Glide updates recently - it’s possible that a change may have broken something.

It’s as if the data didn’t successfully reach google. Saved on glide maybe, for a moment, and then never saved to google and google synced and overwrote it… I’m not sure, but that seems like an explanation. Idk how that could be happening. But I never saw info populate the spreadsheet for your intro, seeking, or bio. I did see it save your location and playlist though. The inconsistency is bizarre.

I’m not sure what you’re suggesting I dig through and look for. The fields in question are simple text entry fields.

I did also email you a loom video. Didn’t share it here since I accidentally included a screen with my phone number.

Are you using any On Submit actions after your edit form is submitted?

One other thought is that maybe there is a conflict with using a Google table as your user table. I wonder if the row is not fully created when you sign in initially and edits get written nowhere. It shouldn’t happen, but maybe a cause. Would you be willing to try using a glide table as your user table? At least with a duplicate copy of your app?

Hey Jeff thanks for looking into this.

Yes I do have an On Submit action. It marks a column for “Profile complete” true.

The row at this point is fully created, because that row is created at login. Further more, that row gets edited when doing the preview steps or bypassing the preview, as well as the row is edited successfully with the prior step in the onboarding, account creation. Account creation uses a Details screen for this sheet… it’s the main user profiles row-owners sheet. Then the profile is edited with an Edit Form screen.

It’s a pretty heavy app with lots of google sheet functions, as well as google scripts running to clear swipe counts and send emails to sms for notifications. I don’t think with all that I could move it to be a glide tables app if I understand how that works.

I see two more glide test users created recently. With those as well, whatever profile info was typed in for intro, seeking, bio etc was not saved (but account creation with contact info and preferences was.)

I was asking about the On Submit action in the event it was maybe wiping something out, but it doesn’t sound like it.

I only ran through your app a couple of times quickly. I’m not sure if I filled everything in. I’ll try again a little later. Another thought is that maybe a user is navigating through the screens too quickly before it has a chance to save anything??? I don’t know, completely guessing at this point.

I will say this though. A couple of years back, my Google sheet did a lot of the heavy lifting as far as formulas and calculations. Whenever data was changed in the app, it would cause my google sheet to start churning and calculating. Sometimes for several minutes. If a form was being submitted several times in rapid succession, then some of those form entries would get lost because they won’t be written to the google sheet until it’s done doing it’s calculations. If a sync occured in that time, then any submissions that didn’t yet sync to google would be lost because they didn’t exist in the google sheet. At the time I ended up creating a completely separate google worksheet, which did the heavy lifting and used Import formulas to move data between the app worksheet and the calculation worksheet. It solved the problem at the time, but led to a large delay before updated calculations were eventually synced back to the original worksheet and back to the app. Since then I’ve moved most of the logic into glide and haven’t looked back. Hard to say if that is the same situation you are having, but it sounds like your sheet is doing a lot of work.

2 Likes

The weirdest thing about this is that the setup I had worked fine for months, which is why I feel like it’s a bug with glide and not an error I introduced.

The On Submit shouldn’t affect any of this as the column its writing to is not the columns having issues.

So, you’re saying if the Google sheet is in the midst of calculating, and glide tries to write to it while its churning, that write might fail? And then the next glide/google sync might write the old google data over the new glide data? I’ve never seen this before but that could maybe be possible. I don’t really think so because the consistency that it’s not writing the edit form info… it’s happening for nearly all new accounts.

Are you still using google to hold the data, and just moving more of the calcs to glide to reduce those churns and syncs? Or do you sometimes not use google at all?

I did some more testing. On my phone, with a new account I saw the intro, seeking, and bio info not populating to glide or google when I hit done. However when I tapped edit profile again, the data was there. I kept going back and fourth changing the data and after a while it eventually saved correctly to glide and google.

I then tried to reproduce using from the dev layout, and the error didn’t occur. Here’s the video of it though. Perhaps I’ll try on desktop again but not from dev view. Loom | Free Screen & Video Recording Software | Loom

Hey Glide team - when is this being fixed? For my users it’s been over two weeks and they are pretty unhappy that a core feature such as editing is unavailable. They’ve been putting up with the recent platform outages and now this. No ETA from Support.