Inactive "Done" button

My App Support link:

Describe the bugs:
The “Done” button is always inactive when the app is first opened. The button only lights up if you press “cancel” and “pencil” three times to open the “edit form.” This only happens in the “Students tab/edit.”

Efforts that have been made:
Removing all components in the edit form does not change the behavior.

How to replicate:
Launch the application or GDE.

Hello, this may happen because of the actions that you give to the send button or because you have a choice required in the form, the button is only enabled if people select the required fields, I think it would be pertinent that you share a screenshot of your actions or your form to catch the error


Yes I have some settings like:

  1. Deadline for submission.
  2. Validate the column filling with “pointer-events=none.”
  3. Required options.

Previously everything went smoothly and this just happened. Suddenly I found a lot of actions especially those addressed to “this item” changed to " - " from other tabs (it looks like there is a structural change from Glide). But I have fixed everything except this part.
The initial attempt I did was to delete the above 3 sections one by one until I completely removed the components in the edit form to no avail in GDE. In total blank only works on my mobile.
How do you think I can track it?

And actually it’s not completely inactive, it only takes 3 times to open and cancel the edit form then the “done” button will light up.


How do you navigate to that form?

Hi Santiago, I’m trying to explain only the part that affects the button:

  1. Pencil/edit button: it works fine.

  2. The CSS shown by the four bottom red lines in the screenshot of the previous thread, includes setting the visibility to bring up the “pointer-events:none” command:

  3. Nothing is checked for the “required” option anymore.

1 Like

I faced a similar issue in an old app on an Add Form screen. I think I duplicated the app and replaced the spreadsheet (in the new duplicate) so I’m not sure which of my efforts solved it but in the end the done button worked again.

Might be worth a shot…

1 Like

Hi Eric, long time no see.
Thank you for sharing your experience. While waiting for other ways, duplication of pro applications seems to require another procedure to move to a new application, right?

1 Like

I think you’re correct. At that time (a few weeks ago) I was able to troubleshoot without any upgrading or switching. I know Glide has been doing a lot of work on the backend, mainly a new computational model, so possibly that is having an effect.

I haven’t followed this development in a long time. Can you give me a clue on how to transfer this paid app to a new app? Can I still use the same application domain?

I had all my apps bulk transferred with the help of a Glide Team member so I’m not really sure. This thread is a little old but probably still relevant.

1 Like

Thank you I’ll try it later.

1 Like

I see this action is needed to downgrade old applications, will pro-legacy be deleted too? In other words, follow the new price?

@Eric_Penn… I have found the bug, the problem is in the value from the screen or special values. Now I move the value to the on submit action and finally, it works normally again. :sweat_smile:
Thanks to all who have contributed.

@SantiagoPerez is this still under development and use in the future?

1 Like

What’s still under development?

Sorry, this column value can be kept to be used in future or is it better to use custom action?

Using column value components (including column, special value, and user profile) is much more stable in my opinion. I’ve heard of too many issues when trying to set values using On Submit. Using the components instead of On Submit makes more sense to me because you are updating values at the same time the row is Added/Edited instead of After it’s Added/Edited. I’ve had really good luck using the the components.

I’m not sure why you are having problems with them though.


I’ve been using column value since it is available and followed by On Submit. So far no problem until now.

This is the issue I bring up.

1 Like

Is it possible that one of your values is taking some time to calculate? Doesn’t seem like it should be the case since On Submit is working for you. You would think that Current Date/Time should be instant, but is your YouTube thumbnail something that’s computed? I assume it’s the built in plugin? Maybe that’s taking longer for some reason, and after a few times in and out, it has finally retrieved the thumbnail, so the submit button activates. Might be worth trying with just current date/time to see how that works.

I do think that you are correct that there is something different with all of Glide’s back end changes, but I haven’t been able to put my finger on it. Seems like the trigger for the submit button is more sensitive than it used to be, and maybe some things take a little bit longer to load, but for the most part, all of my apps have continued to work. I’m not making a whole lot of major changes either. I also have no idea if my apps are running NCM or not. Seemed like they were close to finished in that conversion, a few weeks ago, but I haven’t heard anything new about it in a while.

1 Like

I did face that problem when I viewed an app I haven’t touched in a long while. The “screen values” don’t seem to be read in my visibility conditions. I had to use a default value in a text component instead.

Say I have a screen value called “Payment method” which accepts PayPal or Cash. I used that “Payment method” screen value to show/hide components in the form, but it doesn’t work at all. It seems to be a bug in the new computation model.


I wonder if it’s like that issue we had way back where new versions of components were released, but the old versions were still supported and the only way to get the newer features of the components was to delete the old and re-add the component. Maybe in a way it’s somewhat similar??? Some old stuff isn’t fully supported anymore until those components, screens, actions, etc are deleted and re-added. I’m not sure.

1 Like