"Done" button always greyed out so I cannot update/enter data via my app. Entering/Updating data

I used to be able to add and edit data to number entry fields on my edit form page in my Pro app but the ‘Done’ button at the top right of the screen is now always greyed out (on my phone and also on my Glide screen on my PC) and doesn’t submit the data to google sheets. In the ‘On submit’ box I have ‘show notification’ as the action. I am not sure what I have done to break it. I used to hit ‘Done’ and get the ‘Data updated successfully’ message or ‘success’ icon. Any ideas would be greatly appreciated.
Thanks and kind regards to everyone. Bruce

Do you have required entry components that are not filled? Are you using CSS anywhere to hide components? Do you have a screenshot?

1 Like

Hi Jeff. Thanks for your response. I will quickly check if I have enabled required entry somewhere. I don’t have any CSS. I will get a screenshot and post it. Thank you.

1 Like

Hi Jeff. There aren’t any ‘required’ option boxes ticked. It was all working a week ago but I must have accidentally done something silly while editing and adding new tabs. Other tabs appear to be still editable. Cheers Bruce

Could it be that there is no row to edit?

i.e. you might need to ‘add row’ action first or have some data in the sheet for those entry fields to link to?

@Adam_Crossley I would think if you are allowed to edit a row, then you must be viewing a row that exists. That crossed my mind too, but I don’t think he would have gotten to this screen if the row didn’t exist.

@twobob There were some issues with the edit screen that were recently fixed, but it seems unrelated to your issue. In that case the button was not grayed out, but just would not do the updates. I would try filling in all of the values one by one until the Done button activates to see if one entry component is maybe the problem.

Thank you for your idea Adam. It is a good one to check. The spreadsheet has the row in it and the columns for each item to be added. It has been working for several weeks but seems to have some issue with all the editing I have done.
I have just duplicated the tab and the copy of the tab is working perfectly so I’m not sure what is going on with the original tab but the problem has been SOLVED by simply duplicating the tab. I’ll delete the original and rename the copy and hopefully it will keep working. A big thank you to you all for taking the time to offer your ideas. It’s the first time I have tried the community option and am amazed by your speedy responses. I have spent a lot of time over the last few months reading everyones posts and it has helped me immensely learning how to work with Glide. Thanks again. Regards Bruce

1 Like

@Jeff_Hager Thanks for your time Jeff. I will try your idea of going through the entries one by one on the broken tab and see if the Done button reactivates just out of interest. Regards, Bruce

1 Like

@Jeff_Hager I have just used your suggestion and gone through the entry fields one by one until the ‘Done’ button activated. You were spot on with your first idea of checking if there were any ‘required’ entry fields. There was one buried deep down the list that was accidentally and incorrectly marked as required. I am sorry for not looking more thoroughly the first time and missing it. :pray: Thank you so much. Bruce

2 Likes