Data not loading from googlesheets completely

Hi,

I have a tab in my googlesheets with over 100 rows. However, on Glide, only 10 rows are loaded. I tried duplicating the tabs, cleared formatting, cleared caches, restarted glide, browsers, everything but it doesn’t solve.

Is this a bug?


You don’t mention how many rows the other tabs have. Glide has a limit of 500 rows total in a free app (across all tabs). You have probably hit that limit.

I haven’t hit that limit I am sure :slight_smile: And I have been using glide for over a year. If I cross the 500 row limit, the data will still be visible in data editor but it will say “YOUR APPS STORAGE IS FULL”

This is certainly a bug.

@SantiagoPerez Can you please confirm if its a bug ?

How much data do you have in your Gsheets?

If you think this is a bug, please submit a ticket.

There is an issue I think am seeing lags in sync from google

1 Like

Same, its a bug. I will submit a ticket

It’s around 200-250 rows.

Its a bug. I will submit a ticket

I am facing this bug for a couple of my applications and I saw the same error posted on the glide community.

Is anyone facing this as well? @SantiagoPerez , I think it is a major bug faced by a couple of users. Kindly look into it. Thanks :slight_smile:

@Hassan_Nadeem

We need to look into your app and your data in order to see what is happening.

As @dgabler13 mentioned, you did not say anything about the total number of your data.

You need to submit a ticket. https://glide-help.zendesk.com/hc/en-us/requests/new

I have upgraded my app to see if the issue is persisting or not as I think this is happening because of glides new pricing.

If it persists, I will submit a ticket.