Copying Glide app template doesn't work for a colleague

I have mad this Glide template
But when a colleague of mine tries to copy this to his own account, the browser get’s stuck.
Here’s a video: Loom | Free Screen & Video Recording Software | Loom
Here’s the template: Connected Car Demo App

When I copy it to my “pro” account I don’t have any issues …

Anybody has insights in why this happens?
I plan on using this template for customers so would like to prevent my customers from having the same issue.

Many thanks!

There is a known issue with private templates. They work if you copy them to your own account, but they don’t work if someone else tries to copy them to their account. I don’t think the issue has been fixed yet.

Since it appears to be an Apps project, you should be able to enable copying and you can share it from the published url. Not ideal, but a workaround for now.

1 Like

I don’t get why this is taking so long to fix. It’s a pretty important piece of functionality, especially given that we can’t allow Pages projects to be copied. I guess it’s either a really really difficult fix (hard to imagine that’s true), or it’s just not considered a priority. A bit disappointing, really. </vent>




Thanks Jeff, Darren for the feedback.
Now at least I know I don’t need to look any further.

For this project it’s quite essential that people can copy the templates.
The app might be a workaround for now but still not ideal especially with the data being copied as well and also since apps will be phased out.

I hope Glide can make a priority of this very soon.
It doesn’t seem to be a hard fix indeed.

It’s a bit odd, because I was told it was a priority fix a couple of months ago. So I’m not sure what happened…

PS. I’ve recategorised your post as a bug. Because, it is.


Can I confirm that this is still an active bug? I cannot seem to copy an app template from one account to another, nor is there a “Sharing” option to copy the app.

Yes, it’s still outstanding.

However, if you are the owner of the template, you should be able to copy it.

As Darren said if you are the owner of the template you should be able to make a local copy… then have your colleague create a new team and add you as an editor… finally transfer the app to the new team.

I think that should do it :wink:

1 Like

Actually, you don’t need to do that.
If you are the template owner, and signed in as the template owner, then you can directly make a copy of the template and place it in any team that you’re a member of, by opening the published template in a browser and clicking on the “Copy in Glide” button.

CleanShot 2023-05-28 at 22.38.04

I’ve tested that just now and it works. After clicking the button, the Glide Builder will open, and you can then choose which team you want it in.

Interestingly, that same screen shows a message saying that “Templates cannot be transferred between owners”. That suggests to me that Glide may have decided that this isn’t a bug :man_shrugging:


Thanks guys! It seems odd to be presented with a ‘Copy in Glide’ button that looks the same as the button from apps on the template store, but which does not function at all. That workaround certainly worked in my case though, cheers!


Glide have fixed this issue. Private Templates can now be copied across teams :partying_face:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.