Black screen when try to enlarge image

My app’s URL: https://campusdavinci.glideapp.io/
When i try to enlarge an image (after setting this behaviour in image component) i get a black screen every time.
The image are showed correctly in thumbnail and in standard view but become all black when zoomed.
Try to go to my app than to tab “Percorsi” than click to first button “Trova il percorso in base alla classe” anf than click on 1st item in list.
The image is showed correctly but when click for zoom all become black.
Thanks for the support

1 Like

Same in my app

2 Likes

My enlarge image is working, so must be affecting only certain apps.

Hi, thanks for the response, could it be a format problem ?
I used PNG, in your app which kind of image’s file did you use ?

1 Like

All PNG as well.

@JackVaughan do you know why there are a bunch of strikethroughs on things in the Glide Library? I wanted to share the image documentation regarding accepted file formats here but I see it’s struck out…have been seeing this throughout the library:

Could be a HTTPS issue ?
My images are stored in a website who don’t have a certificate and an https url.

1 Like

If HTTPS issue, I don’t think I would see the image at all? I can see it in the list and on the details page, so enlarging it shouldn’t block it from being rendered…

Shoud i open a support ticket anywhere ?
or this topic can be considered a ticket ?
Thanks again

1 Like

One more question, did you try any other images? Because I noticed that’s the only one in your app and it’s not the same as the thumbnail image?

My rule of thumb…if it isn’t urgent for me to resolve for my app, I wait here but if you need it resolved and it really looks like a bug (based on the fact that you and @V88_Google both have issue), then you can email support@glideapps.com. Please make sure you don’t capitalize the S in support as it won’t go through. :upside_down_face:

1 Like

yes i had tried with 2 or 3 images, if you go to Hamburger menu in the app and select “Orario Docenti” you will go to another image showed correctly in details but blank when zoomed.
i’ll try to do some others test and in case i’ll write to support
Thanks for the replies

1 Like

Yes, it sounds like a bug! Good luck, I hope it gets resolved soon!

1 Like

I had the exact same issue. and it was due to wrong certificate when using HTTPS.

1 Like

@Deena thanks for the heads up. I changed some of the docs structure and thought I’d sorted these. I see what I did now.

Will fix :+1:t4:

1 Like

I have tried to use an HTTPS site as repository for the files and all seems to works now.
So, is this a bug or a feature ? @JackVaughan @Deena
Thanks again

1 Like

I have had no problem with images myself - I store them all in Glide and follow their instructions regarding public urls, so not sure about your question. Good that you’ve sorted it! :relaxed:

1 Like

It works on iPhone and on Desktop but in my Xiaomi Mi i still get the black image.
And in my iPhone the image are showed in low resolution, and when i try to pitch-to-zoom is almost unreadable. :cry:

1 Like

Usually when I read a post about images, they’re not being stored in Glide or they are not public urls. Not sure about the device issue…@Jeff_Hager, master of all things Glide…any thoughts?

Phones are generally more secure than desktop computers. Phones block http links because they are not secure, and can be used by hackers to harm the computers that try to load http content.

2 Likes

:point_up_2:t2: What he said. Using https instead of http would have been my suggestion. Also maybe the ‘Open Web View’ action as an option, but I have issues with that going full zoom without the option to pinch zoom, so have used “Open Link” instead, which opens the image externally with full control to zoom. Works fine for me on android, but from what I’ve read, ‘Open Link’ isn’t as friendly with IOS devices. Haven’t tested it, so I don’t know.

Just another thought for viewing external content, but I’ve recently started playing with the web view component to display PDF’s in app. I actually have it set to wrap the PDF url inside a google docs viewer url to view an external pdf inside google docs inside a web view inside the app. Works quite well actually.

2 Likes

@Jeff_Hager can you please confirm how you’re building the URL to “wrap the PDF url inside a google docs viewer url to view an external pdf inside google docs inside a web view inside the app” that would be really useful - thanks as always.