Can't enlarge image in Android

My app’s URL:

I have a bunch of images (jpg’s and png’s) from different sources (firebase & cloudinary) but the action Enlarge image doesn’t work.
Strangely enough, it doesn’t work neither in my Android (Xiaomi Mi 8 SE) or iPhone (7+).

I’ve read some other cases from users that have this same situation.

Has anyone had this same issue?

Indeed, I don’t see your images when enlarged… My device is an android phone. Strange…

Thanks for checking it out.
I had a user with iPhone and it worked for her, but so far it hasn’t worked in any android I’ve tested.

When I send the image url by email (using the share button when the image is (empty but) enlarged, I succeed in displaying it via Chrome. So the url is okay and it’s not a problem with android devices. It’s a display problem of the enlarged image with android phones…

Exactly, the URL of the image resolves OK, it’s a display issue within Glide…

@Mark @david @Daniel_Sweet sorry to bother you guys, can you help me take a look?