Are Titles Not Searchable?

Have an app where I’d love the user to be able to search titles but it doesn’t seem to work. Are titles not searchable yet? See screenshot below…

What are the names of the Models you’re searching?

I’m referring to the Title that I manually entered at the top, and not the title in the Data section.

So the expectation is that searching the List’s title will display the whole inline list?

1 Like

Yes, I guess so. Search also does not work for Titles that are automatically added to inline lists that are grouped by data in a certain column. Here’s the screenshot of the title generated (Black and White Printers) when grouped by Device Category…

And then here’s me trying to search for that but nothing coming up…

1 Like

What if you add a column to your data that contains that title where it’s needed. Search is searching the rows of data, so your search terms need to be in the data somewhere.

It’s in the rows of data, in the column with heading Device Category. Here’s a screenshot…

Are you displaying it in the details of of the list items? Search will only search data in visible components.

1 Like

Once you click on one of the Printer types, I have the Device Category listed in a Basic Table pictured below…

Then, when you click on a specific printer shown at the bottom, I also have it listed in a Basic Table, pictured below…

Try adding an action text component with the category just to see if that makes a difference.

@Mark is this a bug?

Still nothing. Seems like if I’ve selected Group by, and then select the column where that data resides, and then it displays on the screen, shouldn’t it be searchable?

Your inline name is the first letter in CAP, have you tried Black instead of black?

I know it’s sucks, but glide recognize like this

Just tried that and still nothing.

1 Like


What if you add that category text to the tiles as a details portion (so those tiles actually show the black and white text). Just to see if it works.

Ok, that’s finally working. I added the Device Category as a Caption. But, I really don’t want it right there on top of each tile, ya know? See screenshot below…

At least it works! Haha

That being said, maybe you can rewrite that as a blank value, but still use it somehow. Maybe use a template column to replace it with a blank space and see if it still forces the search to find it…? Honestly no idea if that will work though and this seems like a bug.

1 Like

yeah, I think so, too. And is it normal for the Category to pull up a name that’s for a completely different inline list in this Details section? For example, in the screenshot below, I’m in the Black and White printers inline list, which is really an inline list of All Devices, but filtering only Black and White printers. But, if you look at the right, it’s pulling up Chromebook info…

That’s still likely bringing up the first row of the full sheet to show what would be in the non-filtered list.

Another thing to consider if the blank template doesn’t work, maybe redo your list as cards and include the category in the header value. Might look okay (and work the way you want) while you wait for a big fix.

1 Like