Using an Image Picker in Pages

I created a new Pages project using the base Glide tables (Things, Categories, Back Office).

I went to edit the Things item to upload a new image via the Image Picker and it does not work.

Shouldn’t the ‘image picker’ component allow me to update the image in the table? I have done nothing other than open the Glide data in the Glide Page using the ‘edit’ selection.

Am I using the image picker incorrectly?

Just to clarify, have you pressed the little “x” button to remove the current image and then tried to upload a new one?

Yes. It prompted me with a ‘Delete File’ but still wasn’t able to select a new image.

Cancel restore the original image that I ‘deleted’.



1 Like

On the edit screen, have you:

  • Removed the existing image by clicking in the x symbol
  • Uploaded a new image
  • Waited for the new image to upload
  • Clicked on the Submit button. You cannot close the edit screen by clicking in the corner x, this would close the screen without submitting the data to the table.
1 Like

Cancel should work like that, so that is fine. The Edit screen doesn’t save any changes until you press the Submit button.

When you press the empty image picker field, what happens?

Clicking the image picker fields does nothing. No prompt or overlay to select an image.

I verified I had available space in the My Team Project usage directory.

I’ve recently had issues with the image picker, no later than today. In my case I believe it is due to a poor internet connection.

Could you check your internet connection by:

  • Switching from wifi to data or vice versa.
  • By switching off your vpn or changing your vpn’s location.

If that fixes the problem, your issue is probably a connectivity issue.

Check your permissions in your web browser. You may need to allow access to files or something like that. I’ve seen recently that someone had an issue copying/pasting cells and it was a Chrome permission that was disabled that was preventing it from working properly.

You can also try this in the published project on your device to see if the issue lies in the component, or the device/browser that you’re using.

The upload image prompt never appears.

I have not touched any aspect of this Page. This is the default tables/screens that are created when you selected New Page.

All I have done is select ‘Edit’ from the Things directory and tried to upload a new image.

Another idea: try displaying the edit screen as current instead of overlay or slide-in.

1 Like

Good hint. I published the app and:

  1. Image picker (IP) does NOT work on Chrome

  2. IP DOES work on Safari

  3. IP DOES work on iPhone/Safari

    1. IP DOES work on iPhone/Chrome

Chrome on MacOS is setup as:


Is this correct?

1 Like

I don’t use a Mac, so I’m not 100% sure. On my Windows desktop, I can select “Site Settings” in Chrome to view more details about the permissions the site is using. I don’t know which permission may be blocking it on your end… my assumption is it’s the pop-ups and redirects one, but you look to have allowed that already. If you can view the Site Settings screen, try just allowing it from there instead.

FYI - this continues with a few more options that flowed off the screen.

Thanks Kyle. I set privacy to allow all pop-ups…didn’t work.

Shutdown Chrome - ran again and it worked.

Set privacy back to only allowing Glide for popups and shutdown chrome.

Rebooted chrome and the privacy settings are working and the image picker is picking.

Thanks for helping me down the resolution path!

PS. I didn’t need to delete the image - it popped up correctly by just selecting.


Good to hear and glad it’s sorted for you!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.