Uploading Audios

Hey there! I have been tried to upload small audios with .mp3 which are also public but when I try to play them in the app, it doesn’t allow me to.
It shows this:

Screen Shot 2020-04-25 at 22.10.05

Any guess?

Are you uploading them or accessing a public link? I assume you have the audio component pointing to the column that contains the url? Can you share one of your urls? Are you using the file picker to upload?

Hey Jeff, thanks for reaching and help!
So I am copy-pasting the url from a public domain to the pronunciation column (UDTALE).
Then, at glide I am selecting the Audio Component, taking data from UDTALE.
Then, it appears as shown in the picture (there is a component audio but no means to play it).


I just tried what you suggested, using the file picker and it worked for one verb but no the other. No I am a bit confused. Does it mean that in order to upload an audio, it needs to exist in my computer! first

Thanks

This is how it appears in the excel
The second link, not working in the app

And this one, does work…

change http to https and try that.

Its creates an error in the link…
Seems like the only way to upload an audiophile by previously downloading it to your computer, not straight from the internet
Bugger

I just tried one last thing.
When adding a new verb, I chose the File Picker and from my phone, recorded a voice note. Same thing happens, It shows the recording but doesn’t allow to play it
Ahhh!

The link that’s hosting the audio file doesn’t have a secure certificate for https, so that’s why you get an error. I think you may be stuck because I think you need to be able to link to secure https from an https source, such as your glide app. With that, you may have to either download and reupload the audio through the app, or host it somewhere else.

For your voice note, what format is the file being saved as? It may not be a compatible audio file.

Hey Jeff!
Thanks for your help!
I ended up doing what you mentioned.
Labour of love…
Thanks

1 Like