Audio streaming not working on phone

My app’s URL:

Hi all. My app is in development. Problem is the audio component works when viewing the app in browser, but it doesn’t on mobile. It seems to just fail to load the mp3 file, but there is no error message. I’ve tried on mobile in both Safari and Chrome, both Android and iOS.

Any ideas?

Do you have the mp3 shared? Might not work on mobile if the file permissions are not set to sharing.

I’m not currently seeing any audio components in your app.

Ditto what Jeff said. I don’t see any components on the first page. Show us a screen shot/recording of your app working in your browser.

Thanks for the reply!

Here it is working in browser:

@MMannucci Where is your audio being hosted.
Try alternate host sites
Try creating a “Video Audio instead” (Use youtube with a still image)
Google drive shared audio link works well for me.

Unfortunately, that isn’t really an option… It seems odd that it would work on desktop and not on phone. The link also works on the phone is loaded through a website as opposed to on the Glide App :confused:

Again, do you have the file publicly shared? Usually it will work in the browser because you are signed into your google account. I don’t get the audio to work on my phone or desktop.

Whenever you create a link to a website or item on a website, that website’s server knows you created the link. IF your audio is being hosted on a “Private site” then the security function could be triggered when a back link is detected, this will intern break your backlink. It may not happen instantly but can happen intermittently.

Your audio probably works on your browser because cookies were detected as an authorized user for the content. Your audio does not play on my browser.

Public hosting sites give you authority to back link to their content, but other private sites would break the link.

Wouldn’t that mean I couldn’t access it while in incognito mode? I still can, though.

The real test would be to try on a different computer…

The link is streamed from a public website by all kinds of people.

Here’s the site:

This is actually a private website with their own Copywrited content.
© 2019 Westminster Chapel. All Rights Reserved | Website by [Sola Web Design

Public media distribution sites are
Youtube vemeo, etc.
Option 1. Try to see if they have the same clip on youtube.
Option 2. Do not use a file streaming ripper to download the content and then use it in your app. This could be copyright infringement. :slight_smile:

I made the website. I attend the church.

This still doesn’t explain why the link works everywhere EXCEPT the Glide App on mobile. Very strange, and essentially makes the app pointless as it prevents one of the main functions (accessing the church’s sermon audio on the go) :frowning:

What’s the link look like in your sheet? I opened the link and the hosting site doesn’t have a valid certificate. If you have HTTPS, try changing it to HTTP.

You may have already bypassed the certificate on your local machine, so that’s why it works.

I have tried both.

Did the website link I posted for you work? If you have not bypassed the certificate it should not work on yours, correct?

The website worked, but the audio is hosted here:

That is the link I have in my Google sheet. I tried with http and https… works everywhere except on the phone.

Now it’s working in my browser. Probably because I’ve bypassed the lack of a certificate. It may be forcing SSL (HTTPS) even though the hosting site does not support it. This could be a problem in the future as Chrome is cracking down and will now longer allow HTTP links anymore. Only HTTPS. I’m going to lean towards a problem with the audio host.

What solution would you suggest I propose to the gentleman who manages the hosting of this audio? This stuff is a bit over my head.

They would need to get a valid certificate for the server. The certificate is registered to, which doesn’t match Looks like ezrainstitute is hosted on AWS so would need to possibly contact AWS to see what’s going on or maybe start with ezrainstitute to see how they have their site set up. This is all speculation, but it’s my best guess why it’s working in some cases, and other times it’s not working.

1 Like