Audio element not working

My app’s URL:
Testing on iOS, and desktop Mac OS via Firefox

I can not seem to get the audio component in detail view to work.
The component is linked to:

an .mp3 file on my web server…

www. astroman. com /media/05-junk-satellite-1.mp3

Which works just fine opening directly in browser URL, but in glide it shows a 0:00 duration and will not play (wow, as it is inside this post as seen in the player above which I did not add, I just added the URL for the .mp3):

1 Like

All file links must start with https://


WOW- i saw Man or Astroman live back in the 90’s!! great concert and fun fun fun musical style.

1 Like

Hmm…Ok, well https does not currently resolve on my server. So I will look into that. Thanks. Meanwhile, I have also tried to link to it stored on Google Drive, but that does not seem to work either, since the google link is a file ID not a .mp3. Is there anyway to use it via Google Drive?

Ha! Small world! Thanks!

Why not use the File Picker component to upload your file to Glide directly? Then it will just work.

Your audio file does not exist, my friend.

Our content is generally user contributed and I prefer to have maintain that content hosted on our own server, and one that backups to a physical drive in our possession. This is partially a philosophical choice, but it also facilitates migration to other platforms should that ever become needed. Currently when a user uploads a file, I run a Zapier script to duplicate it to my Google Drive (which is also synced with physical drive via Google desktop), and then update the sheet row entry to point to the google drive. It would be great if Glide could allow playback of .mp3 file via Google drive, but I can work around it. I might use the Glide file version for .mp3 files for Glide usage, but still have Zap to make sure I also have a copy locally.

That is what happens when you use https.
But try is http://

Download the audio, then upload it to google drive.

Interesting…I just used the File Picker, and uploaded an .mp3 as you suggested.
Same issue.
See screen shots on Firefox and Safari on MacOS.

Any ideas?

Turns out I do not have an SSL cert on
Adding now, and will retry.

1 Like

Pablo, Regarding the use of google drive, getting to Google drive is not the issue, it is that the Audio component of Glide does not recognize the google drive file as an audio file, since the link given by Google does not end with an audio extension. Is there a work around that you know of ?

It works for me - have you made sure that you’ve turned on sharing?

Here - try this one as a dummy one

Ahhh…so when I use my ZAP to upload to Google, it just uploads it but does not change the sharing to “Everyone…”
If I manually change sharing…it works!
I will need to add a step in the zap to modify sharing.


Works! Thanks Pablo for your help.