Understanding how CHOICE interact with Sheets


I’m trying to get a full understanding of how the CHOICE component works with Sheets.

Let’s call my target data field STRAND_1. When an app user makes an entry to that field in Sheets via the CHOICE component, the entered data appears in the field STRAND_1 of my Sheet and other app users see it populated in their own view of the CHOICE component. Great.

But if I write ‘foo’ into STRAND_1 by some method other than the CHOICE component (like by tying directly into Sheets) Glide doesn’t see it. Even after refreshing data from within Glide, I still don’t see it in the app.

So, Glide doesn’t appear to actually be reading the cell associated with STRAND_1. It looks like it has formed a relation between my [CHOICE list] and the [STRAND_1] and is tracking that somewhere within Glide’s own code. But where? If that’s the case, how can I trust my data’s integrity? Appreciate any insight into how this works. Thanks!

If a value, such as foo, is not in your choice list, then it won’t have anything to highlight in your list of choices because there is no match. Glide tries to find an exact match between what’s in the column your choice is writing to, and whatever you are using as the source of your choice list.

If it’s possible for a user to type in their own values outside of what’s availble in the sheet you are using for your choice options, then you need to find away to populate the choice list with those new values. There’s a lot of ways to do that. If your data is in a google sheet, then you can use a unique formula to pull in unique values from the sheet the users are entering data into. You could also directly point your choice source to the sheet the users are entering data into. There’s probably a lot of other ways to do it, but it all depends on how your app is set up.

Hmmm. So, if I’m understanding you, Glide is looking at both the Data field (Strand_1) and the Choice list and highlighting the string that matches? That may be part of it, but there’s more to the story because I can’t force Glide to show ‘Foo’ after I’ve A) Entered it directly in GSheets and B) gone to my choice list and added it there as well.

If it were as simple as Glide looking for a match, the app should have picked my manual entries described above and displayed Foo in [Strand_1]. But it hasn’t.

It seems that there’s a mechanism whereby the CHOICE component is not able to show data from my target field unless it was entered using that CHOICE component. If that’s the case, I will find a work around, but I really want to understand what GLIDE is doing here.

Thanks for your input Jeff!

That shouldn’t be the case. If the same value is in the choice list as well and the target column, then it should show up. Are you saying that you added foo to the choice list, but it’s not showing in the list? Are you sure that it’s spelled the same with the same upper and lower case letters, and no extra spaces? Can you provide screenshots?

So, pls ignore data in columns J:N. They are not in sync with the app for the reasons in question here.

Looking at Column 0 [Strand 6], you see I’ve typed in “Foo:” That’s where the app would have stuffed the output of DATA Column

Then in Column H of the other sheet I’ve entered the same thing, but my Glide doesn’t recognize it.

One possibly important note: the choice list [concat_dev] is a concatenation of two other fields. I entered “Foo” into source column and let GSheet append the : (leaving second half blank). Column H was set to Format: Automatic. I’ve tried forcing it to Plain Text, with no success.

I’m gonna go build a dummy app with simpler parameters to make sure it behaves consistently.

Screen Shot 2021-01-24 at 2.45.43 PM

First thing to check: Does the Dev_GEN sheet in the glide data editor show the Foo option?

Next check if you have any filters set on your choice component. Are you possibly filtering out anything that include ‘:’ as a choice?

Good thought… but, yes I see Foo: in the glide Data dev_GEN page.

And there are no filters. I’ll build a simpler version and if the problem persist, I’ll share the app and GSheets here.

Screen Shot 2021-01-24 at 6.16.08 PM

1 Like

OKay, for anyone who’s cares to know how this turned out, I believe the unexpected behavior described above may be an isolated instance.

I created a simple app with just two sheets and some choices. The CHOICE component works exactly as I’d expect it to: I was able to manipulate GSheet entries directly in GSheet and see that data reflected correctly in my Glide App. This worked regardless of whether the entries in GSheets were simply typed, or the result of a concatenation formula. It just works the way you’d expect it to.

Clearly, I’ve got something pear-shaped in my original app. I’ll find and fix it. Thanks for your help Jeff!