Unable to show more that 10 rows in a Choice field

I have an app that takes user input from a predefined list. Recently i am unable to show more than 10 items in the drop down. Please note that i have note selected “limit number of items” option.

While this was working earlier and i was able to show more than 10 options in the drop down, now i am not able to show more that 10 options in the drop down in the “Choice” field created for user input.

I just tried to replicate this, but I can’t. A couple of questions:

  • If you look in the Glide Data Editor, do you see all options?
  • Are you working with a Glide Classic App?

I do not see al the options in glide data editor. The strage thing is even if i add all the items in the Glide Data editor, it gets added and i see it in the google sheet also in the app for a few mins. But after that it again goes back to the same state where i see 10 items in data editor and the app.

I am on a premium plan. I do not know what is glide app classic

That seems to suggest that there might be a sync issue. If you go to the Data Editor and force a manual sync, do you see any errors?

There is no such thing as a Premium Plan.
You could either have a Team Based plan (Free, Starter, Pro, Business or Enterprise), or a legacy per App plan (Free, Basic, Pro, Private Pro).
You can tell if your App is a Classic App by viewing it on your main dashboard. If it’s a Classic App, you will see the word “Classic” just below the App icon.

1 Like

Yes, it is a classic app

A lot of things not making sense here.

Your very first screenshot shows the choice component starting with Banana, whereas your sheet starts with American Nuts. That doesn’t make sense. Even if a table was only syncing 10 rows, it wouldn’t skip the first row.

You never showed what the data editor looks like in Glide. I don’t even know what data you are showing in your third screen shot. That data snippet is showing a RowID column, but I don’t see a row ID column in your sheet, so I don’t think you are showing us data from the correct table.

You never answered Darren’s question regarding what happens when you force a data sync. It’s hard to say if you have a sync issue, or if you are using the wrong table.

You never clarified which plan you are on. As Darren mentioned, there is not and has never been such a thing as a Premium plan. If you are on a free plan and you exceed your row limit, then it is possible that some tables will be truncated to 10 rows. It would really help to know which plan you are on, as well as where you are at for your app’s usage quotas.

I think the least relevant piece of information here is that it’s a Classic App. Shouldn’t really be that important as far as the issue is concerned.


Hi @Blaids_Hearing , do you resolved your isue? I have the same probleme for the moment. Impossible to make choice list for more 10 items. If i add new line in my google sheet, Glide remove line randomly during the sync

Which plan are you on?
Where are you at as far as your usage limits for your plan?

Hi @Jeff_Hager , I m not to the limite 180/500. But after some test it is not a choice limit but a sheet probleme. If a create new sheet with only 2 columns, I’m not able to hav more 10 rows. I add 3 more columns and i can have more than 10 rows, is it Bug?

I can kind of reproduce the issue, but not exactly as you say. Definitely seems like the manual sync is unreliable.

Have you tried simply refreshing the browser window?

Same probleme in new browser

I’m not sure what to say. I’ve seen weird things in the past, especially when you have other unused tables in your google sheet. I’ve had cases where the combination of used and unused tables would technically exceed the plan’s row limits, but the tables that were actually used by the app, had a cumulative row count less than the limit. Regardless, because of the extra unused data, it seems that glide will not willingly sync more than 10 rows in some tables. In my experience, it has usually worked itself out and returned to normal after a few days. Maybe it takes a while for Glide to realize which tables are used, and which are unused, and assign priority to those tables that are actually used by the app. :man_shrugging:

I guess if you have extra unused tables in your google sheet, you could try removing them from the sheet itself, so your total cumulative rows across all tables are less than 500.

Moving this to Report a Bug and opening a ticket with the dev team. :+1:

@Steeve_Richard - Are you also having this issue in a Classic app?


Ok for thicket

Is it on classic app.

@Steeve_Richard @Blaids_Hearing

Thank you both. Two questions for you:

  • Which plans are you on? (Free? Starter? Pro?)
  • Can you provide a support link to your apps? More info here.

Dear all, it seems to me I have the same issue with unused sheets…Would it be possible for someone from glide to check my app?


I am on a starter plan (not classic app). If I sum the row usage stated in “usage” web-page on glide and the viewable rows in the editor of the unused sheet (I have one unused sheet on the google sheet) it makes exactly 5000…which is my row limit…

I have been waiting for more than 2 weeks to see if this would have been soved on its own…

Thanks to anyone giving help!