Suddenly, data stops reflecting to Google Sheet [urgent]

My app’s URL: covidsos.org - this app is helping people in india find emergency resources. Any help would be appreciated here.

I’ve made a loom video as well. Loom | Free Screen & Video Recording Software

It was all working fine upto 12 hours ago, when I added a formula in one of the sheet’s column where Glide App is supposed to add rows/data. Since then, (I realise now), the submissions from the app (Form or Submit Button) is not being added into the google sheet.

I deleted/re-created the sheet that was causing the issue, created new buttons for the functions involved. It’s still not working.

If you submit any data from the “about” button, it’s not reflecting into the google sheet.
If you submit feedback or report fraud, that is not reflecting into the google sheet.

I am unable to decipher what is the error and if there is a solution to this or is this some kind of a bug that causing this unusual behaviour.

Last option (that I am currently working on) is creating a new google sheet and trying to replace the existing one with this new one. It still looks unlikely if it’ll work…

Please suggest or help…

Thanks

Scroll down to the end of the Google Sheet.

Thanks David for the input… I have done that and checked if it’s adding rows at the bottom. it’s not adding any new rows to the sheet.

If you check the “about” tab on covidsos.org , it has a button called “add verified info” which has a form. That form’s submit button is connected to a different sheet in the google sheet. Data is not updating in that sheet too.

Your app could have a bottleneck—are many users editing the same row in the Google Sheet at the same time? If hundreds of users are doing this at once, it could be causing too many changes at once.

There are 4-5 people who are updating sheet with new information at any point. But i am using =query() function in the mainsheet and people are making the edits in a different sheet. The mainsheet is locked and not allowed for users to edit.


Sheet called “database” is not editable by anyone except me. I’ve used “query” formula there.
4-5 people are making edits in “RawData” sheet typically at a certain point.

Please make a loom.com video showing the data submission in the app, and the connected sheet, scrolling to the bottom. Then open a support request and attach the video.

1 Like

Here is the loom video showing how the data that I’m trying to add is not updating in the sheet.
I’ve also scrolled to the bottom of the sheet as suggested. Apart from this, I have also created a support request a while back as was suggested by some other users too (with a loom and a glide support link).

Waiting to hear back from the team.

In the meanwhile, if there are some things that I should try do to help the team identify the issue sooner, please let me know?

Thanks

Hi David and team, I created a very simple form within the app to test it’s working. (it’s connected to a new sheet within the google sheet). Turns out, it’s still not updating.

Currently, I am trying to reduce the load on the sheet by moving workings to a different sheet and then using an IMPORTRANGE to input changes here. I think that might reduce the burden on the glide process…

In the meanwhile, is there like a cache that can be cleared/reset (basically a reboot equivalent) which can try to make all my google sheet connections again. I am hopeful that might make things work.

The next few hours might be a good time to press the button on that since it’s late night/early morning in India and we might not face much of a disruption/issue.

Thanks for the constant and prompt response, appreciate it.!

Hi @david I have replaced the underlying sheet with a new google sheet. Things are now working. I don’t know what broke the connection but looks like the google sheet-app connection broke…

:white_check_mark: :white_check_mark: :white_check_mark:

3 Likes

Hey Glide Team,

I just checked with @Siddarth_Jain and the Google Sheets to Glide integration has completely broken down. We tried duplicating the app as well and it still did not work well.
Never seen this happen before. This app is being used by thousands every hour. It’s important for it to work well.
@david @Mark

Thanks for your help in advance.

2 Likes

Hey @david and the community - I just woke up and unfortunately the same issue has re-occurred. I created a new base sheet - which no collaborators and 1 importrange to reduce on the editing frequency.
Additionally, I also moved all sheets with backend work by volunteers into a different sheet. It seemed to be working when I hit the bed, but looks like it’s not working now.

From what I can understand, none of the changes from the glide-app (glide table or an app form/button submission) is reflecting into the Google Sheet.

Would appreciate any support here… This is the new sheet (making it public so you any of you can help in troublshooting) - CovidSOS master data - Google Sheets

Also, I’ve shared the support link to the app in the support ticket already…

I don’t know if this helps, or is even related, but I used to have a lot of problems with my app when there was rapid data entry. I used to have a lot of calculations and formulas in my sheet that would cause it to process for several minutes every time new data was entered from the app. I think when this processing is happening, then new data can’t come into the sheet until it’s done. What I think was happening in my case, was that new data was waiting for the sheet to finish processing so it be inserted, but at some point a resync happens and that waiting data is lost. I have since gone through and moved a lot of the calculations into glide and restructured a lot of data to make it more efficient. There is still one piece where I need to run individual queries on a few thousand individual rows and that takes a long time to process. To fix that, I am using an ImportRange to pull the data into a completely separate spreadsheet (separate workbook), let it do the heavy calculations, then I have an ImportRange that pulls the calculated data back into the main spreadsheet. Sounds like you may be doing something similar, but it really freed up the processing from up to a 10 minutes, down to a couple of seconds. Ever since then, I’ve much better luck and little or no data loss. If your sheet is doing a lot of spinning and processing, then I have seen that be a cause of issues. I’m not sure if that’s your problem, but you had mentioned formulas and separate sheets, so I though it may or may not be similar.

3 Likes

Here the problem is that the data is never syncing to the Google Sheets at all.
I can see it in the Glide Data Editor but it doesn’t reflect in the Google sheet. Even with a delay. This is the first time I have seen this happen.

1 Like

@Manan_Mehta Could you give us a support link to the app, please?

I do not have access to the app.
@Siddarth_Jain you can share your support link here.
I believe he has already shared one in his support ticket too. @Mark

Hi @Mark here’s the support link to the app - Glide

Let me know if you need anything else

I’ve been running into all sorts of issues of late. Something is not right anymore. Sheets are not syncing, keep getting “not responding” glide messages, takes 1 minute for a button to appear, another 1 minute for text to appear, another 1 minute, and another 1 minute and another 1 minute it’s like an endless lag cycle now. Apps with afew sheets work fine but large amount of data the editor is struggling to cope with. By large I don’t mean anything on the scale of your concepts app but some 200 rows spreading over the entire app.

1 Like

It’s been a little while since I’ve done anything in glide. As far as I know, my main app has been running normally…or at least no complaints, but maybe I’ll have to check again.

1 Like

I’ll be sending in a lengthy video to glide in next couple of hours. I’ll post it on the xuber hotel thread too just to show you guys what I mean and why I’ve had to put that app on hold. I don’t know what it is but it’s really strange. My only worry is Glide will come back to me saying you have too much data which would really kill everything off because I just about started focusing on the more complex apps. My dream of seeing your clickable dynamic calendar in action may not be realised after all the effort I put into it​:pensive:I’ll post what I have finished and it took me more than 2 weeks only because each component takes 1 minute to load. I know my laptop is not infected. :frowning:

@Wiz.Wazeer

What do you mean (or Glide) with “you have too much data“??

Are you loading too many columns/rows from a GS or your APP has too many relations and computed columns internally?

Saludos