"sorry, the file you are searching for has been deleted"

i 'm coming back to glide after one year and most my apps are blocked with that kind of message when i try to see data sources… (google spreadsheets)
so i can read my data it but i cannot change it…
? what are the changes ?

It sounds like your Google Sheets have been disconnected from your apps. Did they get deleted or moved? Did you lose access?

…sorry i’m french :wink:

indeed , last summer several google sheets have desappear from my drive …without a known reason …

is it possible to re-create them from my app (seems to have all my data still in glide app) ?

You may be able to export your app’s data in settings, recreate the Google Sheets, then reconnect them.

Duplicating your app may also create a new Google Sheet…

i can not duplicate any of my app . It always answer :

same for both options “keep same sheet” or “Copy the sheet” …?

Other solution : How can i reconnect the export file to the app ?

You should be able to do that now.

?? you did something ? …nothing changes for me …

You can export the data here under the data tab, using the “Export App Data” option.

Then after you make sure the exported file is uploaded to your Drive as a Google Sheet, click the 3 dots button and replace the current one to the new file.

thanks , yes i tried this : in Chrome it ask me to sign in

and a white window appear briefly, and desappear and Error Message

in firefox it goes better : it open a window to " select a file " but it crashes after


i tried with different glideapp (different sheets) but same effect …?

My browser are updated …but i’m in France …maybe ?

Happy to hear - welcome back !

That’s weird because at the point when you are able to do that inside the builder I thought you are signed in with an email already.

Do you have any extensions with Chrome that may affect this (say Ghostery, Ublock etc.)? Can you try turning them off and do it again? How many rows do you have on that Sheet?

ok i fixed the problem with Chrome extension (caused by an “anti-tracker”) .
but i 'm going back to the same windows as for firefox … “all columns are missing” …and the app cracked
so …i export data, import as googlesheet , try to replace and that error window always come
my file (contains 3 small sheets ( 40 rows x 10 columns max) )

some links (to image in my drive) are broken : i deleted them
other link (like https://firebasestorage.googleapis.com/… or https://storage.googleapis.com/glide-prod.appspot.com/uploads-… ? what is the difference ? ) still works
i try once again deleted that links and once deleted all the row (except title) and …always same message

one more thing : i do all that because, after one year without using my app, it seems that something changes because i cannot modify my data : if i delete a record, it comes back after refresh …
i see in other post that it happen to other user …