Some Input components don't seem to be working

Not sure what I am doing wrong, but input components - tried text entry, image picker - don’t seem to be working for new apps I create. Observing this since Monday Nov 30 EST night. Form and components inside form including text entry and image picker are working.

All older apps are working fine.

For the app in the video above, I have set up a User profile page, public with email. Added email, image picker.

Tried another app with same sheet, Public, added a text entry, did not work.
Support link:

Doesn’t look like it has a row to update. If the entry components are greyed out, that usually means there is no rows in the sheet or you have set your filters to exclude all rows.

1 Like

As the video shows, there are no filters applied. The sheet attached has these columns: Name, Email, Avatar, Role.

I’m not sure what you mean by this.

This is how it is mapped

To your point of “doesn’t look like it has a row to update”, I thought it might be because it is not recognizing any user, but then I have developed other apps in similar way. Could it be because of default hide users? But then i tried another app with same sheet. Set to “Public”, no email. It is mapped to the user sheet, the text entry is still greyed out. Don’t think that’s the expected behaviour. Though I am curious to learn for what use cases it is greyed out.

Hi @abhilashabhatia was searching forum for anything similar for you, stumbled upon this - it’s kinda of related to your issue

There are a few pointers which may help you resolve.


Is Email Id with which you are previewing the app maintained in the User Sheet? If not please maintain and try.


As others have said, doesn’t look like you’re previewing with an email that exists in the profiles sheet. Can you verify?


I believe @Jeff_Hager means that there needs to be at least one row (apart from the column headers) in the sheet.
I’ve found the same behaviour. What I normally do is just enter a dummy value somewhere in the first row, and then everything works.


Your video only showed the features tab of the individual components. I would like to know if you have a filter set on the details screen itself. Click on the features tab when you are viewing the list of components on your screen. Not the details of each individual component.

Thank you everyone for your replies.

There are no filters set on details screen itself.

The preview as is selected, but no row has been entered in the Sheets.

So not a component issue but an issue with recording data into sheet. Not sure. Anyways, manually entered data into sheet. It’s working now.


The only time it will automatically add a row to the user profile sheet is when you actually sign in through the published url. There is no sign in process through the editor as you are always signed into the app, so it will never create the row for you when viewing through the editor.