Short link automation through Make to Google Sheets now not working

Why is all my stuff breaking recently? Am I the only one? :sweat_smile:

I have an automation that turns business profile’s deep links into short branded links so that they are more share-friendly

the automation goes from Glide trigger :arrow_forward: :arrow_forward: Make :arrow_forward: Google Sheets. It had been successfully working for a couple months but now this happens when the automation hits Google Sheets:
Loom | Free Screen & Video Recording Software | Loom

The check box turns to true and doesn’t apply link.

I have another short link automation that does the exact same thing - except I build those profiles on Glide tables - and that still works perfectly fine! So i’m thinking this is a Google Sheet / Boolean issue?

Glide shorten deep links likely… this might be an issue

I’m sorry Uzo I don’t understand

Hey @Katelyn_Alberts,

Can you share the action and data from Glide?

is this what you need?


1 Like

Thanks @Katelyn_Alberts,

Seems like the short link isn’t writing. The actions look like they’re configured correctly from Glide. Have you tried contacting Make support?

1 Like

Hi @Katelyn_Alberts

From your videos it seems that Make is writing to the boolean column instead of the shortlink one. Have you checked that the the Gsheets module in link is set to the appropriate column?

Santiago was right here. Seems like new columns pushed the value to be written to a wrong column.

Please note that when you add new columns to the Sheet, you should always add it to the right end if you have already configured something with Make. If you still want it to be inbetween, make sure you change the settings in Make.

I have updated it for you.


Hi thinh. thanks for the update! Just wanted to ask about a couple things if that’s ok!

Jesus told me he moved the link placement from AS to AR because AR was the correct column on Sheets:

But on Make the Screen URL is AS. Did you move it back to AS? That’s where it was originally when i made the video.

I’m not sure how the columns got screwed up, I do everything in Glide and almost never look at my Sheets until there’s a problem (like this). When I make columns in Glide I often do this:

Is that wrong to do because it may eventually screw up the flow in Sheets?

Seems like I may still have an issue with the URL placement though - let me know what you think!

As noted in the private message, I don’t have access to the Sheet so I set it up based on what I see in Make.

I refreshed the connection and it seems like the Screen URL link is now AR.

Next time, I would rather change it on the Make side. Changing it on the Sheet side might make other column configurations, if any, have a problem.

I believe any columns that are added from Glide will be added to the right end of your sheet, thus not affecting anything in Make. I just tested and it’s the case. The incorrect column mapping here suggests that there has been changes made to that sheet since the original configuration, though.

1 Like

oh my gosh, so what you’re saying is…all i had to do was refresh the connection between Make and Google Sheets and it would have automatically updated the Make columns to match? And the short link column in Make would have adjusted from AS to AR? Because you’re right, I just tested and it’s fixed. Also noted, I won’t add any random columns in Google Sheets, only at the right end.

No, as far as I’m aware if you move columns around in your GSheets then you need to manually adjust your related Make scenarios. It’s one of those things I find a bit annoying about Make - that it’s not smart enough to deal with moving columns (like Glide is, for example).


Just to be clear, I adjusted that for you before the screenshot.