Link from Google Sheets to Glide

Hello,

It is possible to add in Glide a link from Google Sheets which was automatically create with Make.com?

What do you mean by “link”?

Just a shortcut to open the Google sheet, or do you mean to have a new Google sheet integrated as tables in your app?

2 Likes

I want to put the link in one of the table. For example, I generate a PDF with Make, and I want to put the link of the PDF back in Glide.

Your options are to configure to your Make workflow to either update the google sheet, or update the table through the Glide API.

If you mean to display a Google Sheets table in Glide, you don’t need to involve third parties because Google Spreadsheet already has the “Publish to Web” option, and you can embed it with web embed (PDF). This will be updated every 5 minutes.

1 Like

So, you think it is possible to add from Make to Glide the link with Glide Api?

Yes. Several people already use Make to update data in Glide.

This may be useful video unless someone has a link to a better tutorial.

There is also a new Glide integration in Make, but it’s still in beta and I’m not sure of the status of it.

2 Likes

Ok.
I will give it a try.
Thank you very much!

2 Likes


Can you tell me what to put here at the Value? Is The secret Token?
Because I follow all the steps from the video but I don’t know why it doesn’t work…

Yes, for Authorization you need your API Key. It looks like Bearer .......

1 Like

I entered it and it still doesn’t work.
This is the scenario, maybe this will help you to understand. I don’t understand what doesn’t work.


Doesn’t work in what way?
When the scenario runs, there will be a log. If any of the modules fail, their will be error messages. You should examine those errors and see what they are telling you. If you don’t understand them, share them here and we will help. But we can’t help much with “it doesn’t work”, I’m afraid :man_shrugging:

By the way, when you see values in black like those shown below, it means that Make is referencing values that no longer exist. So you need to check those and possibly reconfigure them.

When I introduce in Glide, this scenario works perfectly. I mean I don’t have errors, but it introduce nothing to Glide. Or I don’t know to recognize the errors:))


Screenshot 2024-03-01 135114

Here is your problem :point_down:

CleanShot 2024-03-01 at 19.54.55@2x

Status code 400 means that the API call failed because it was a “Bad Request”.
This usually means that your JSON payload was malformed.

Copy the JSON string from the Output Bundle 1, and paste it into jsonlint.com and click validate. If it doesn’t report green, then there is something wrong with it.

Error: Parse error on line 1:
“appID”:"xlgs6X79kDoSrfNF3M
-------^
Expecting ‘EOF’, ‘}’, ‘,’, ‘]’, got ‘:’

I don’t understand what this means, can you help me please with some more explanations? Thank you very much!

Paste the entire JSON string here, and I’ll take a look.
Please enclose it with triple-backticks ```
That will preserve the formatting.

{"appID":"xlgs6X79kDoSrfNF3MuE","mutations":[{"kind":"add-row-to-table","tableName":"native-table-MmhYiCaopgv6H58GbI9G","columnValues":{"BqisW":"OANCEA STEFANIA","CejPM":"2024-02-29T22:00:00.000Z","Pqa1v":"https://drive.google.com/file/d/15FkYQJOLm6HTxKFkqWQ9fW2RhpYd3XNa/view?usp=drivesdk","TXgIM":"GENERIC 1","cwNUj":"OANCEA STEFANIA"}}]}

Actually, that JSON is fine. Which I guess is to be expected if you are using a JSON module to create it.
Here is what it looks like when properly formatted:

{
    "appID": "xlgs6X79kDoSrfNF3MuE",
    "mutations": [
        {
            "kind": "add-row-to-table",
            "tableName": "native-table-MmhYiCaopgv6H58GbI9G",
            "columnValues": {
                "BqisW": "OANCEA STEFANIA",
                "CejPM": "2024-02-29T22:00:00.000Z",
                "Pqa1v": "https://drive.google.com/file/d/15FkYQJOLm6HTxKFkqWQ9fW2RhpYd3XNa/view?usp=drivesdk",
                "TXgIM": "GENERIC 1",
                "cwNUj": "OANCEA STEFANIA"
            }
        }
    ]
}

I suspect that when you copy/pasted into jsonlint earlier, you just had some extra characters.

Anyway, that means that the error is elsewhere.

And… hah! I see it.
You are using the wrong API endpoint in your HTTP module :point_down:

Instead of the above, you should be using the following:

https://api.glideapp.io/api/function/mutateTables

Give that a try…

1 Like

It still give me the same error…

Okay, well just two more things to check:

  • Add a second header value
    Content-Type : application/json
  • Double check your Bearer token. Make sure you haven’t copy/pasted it incorrectly, and especially check for any extra spaces before or after.