Setting empty cells with set column and increment not working

I’m trying to set a user specific column from empty to 1 (or even 0) by tying it to a button press so that a visibility setting can be enabled but nothing I do seems to get it to work. I’ve tried Set Column and increment, using 0, 1 and +1 but the cells remain empty. Am I missing something?

I had the same issue. When this happened to me I hadn’t set the tab conditions.

Click on the tab settings and set email to “is” “signed in user”
It may be trying to write it to the top row not the user row

Thanks Dale - I looked at all of my settings and that doesn’t seem to be the issue. I’m using both my profile, as well as a test profile, to view the changes in the Date Editor but it still doesn’t seem to set the columns. @Jeff_Hager do you have any sage advice you can spare?? :pray:

What is the column type?

The way I generally do this is with a Boolean column, and then toggle it between true/false (lowercase)
It always works.

Good morning / afternoon / evening Darren! It’s a number column but only because it’s tied to an accordion-like menu where visibility is dependent on 0 and 1 being present. I tried creating another user specific Boolean column in the sheet (where the T/F would have been tied to an ITE column to modify the number column) but when I added the checkbox, I couldn’t actually check it. It was grayed out :man_shrugging:

Just approaching midnight, thanks :laughing:

Is there at least one row of data in the table? (in addition to the header row)

If that doesn’t help, can you share a few screen shots or a short video?


This is the sheet in question (there are multiple columns which is why the pic is split in two). As of right now, the user specific columns are empty in all other users’ profiles (this one is mine, which is why it isn’t empty) and I’m attempting to set the columns to 0 on a button press. That wasn’t working so I went the checkbox / Boolean route and that hasn’t worked either. In fact, I tried it again just now, even going so far as to change the column type specifically from Boolean to text so that it could populate “true” on check but the checkbox component is grayed out even though it’s tied to the user specific “Activate” column

The checkbox is greyed out because you’ve pointed it at a text column.
Checkboxes and switches can only set boolean columns.

Still grayed out :man_shrugging:


Running out of ideas… how are those other user specific columns populated, and what’s different (if anything) about this one?

Have you tried deleting the component completely, and adding it again?

If something is greyed out, that usually means you are not attached to an existing row. I would double check your settings.

@Darren_Murphy Deleted and re-added all of them multiple times

@Jeff_Hager what settings should I be checking for? The checkbox doesn’t give me very many options and I’m pretty sure that I chose every combination of options (between Set Column and increment) in the Edit Actions on the button

I would check to make sure you don’t have any filters set in the features tab of the tab settings. It wouldn’t be any settings on individual components on the screen, but instead, the entire tab.



I had one filter (to hide a picture) and I removed it then the component popped up. Thank you @Jeff_Hager and @Darren_Murphy for your help!

1 Like

Also, just out of curiosity, why should / would a filter on the tab affect the ability to alter user specific columns?

If the filter on the whole tab excludes all rows in a sheet, then there is no row to update. The screen is just kind of floating there with no underlying row and it wouldn’t know which row column to update. With no filter, it will attach to the first row in the sheet. If a filter does find a match, then it will attach to the first match.


Last question: I need other-than-the-first-row to be set. Is there a way to do that?

What’s the criteria? If you need a different row to be set, then set the filter accordingly.

I need this row set:

I’m not sure where or how to set a filter accordingly because I had a filter on the tab and that’s what was keeping it from being set in the first place

How was your filter set up before? Is ‘Treatment Protocols’ always going to be the row you update. If you are getting to that row from a list, you will already be on the correct row. If this is just a tab, then you need a filter the tab to get to the correct row. That’s why I ask what your criteria is for setting values in the second row. What would tell Glide that the second row is the one you want to update?