Set column not working in relations...distinct

My app’s URL: https://deft-salt-5823.glideapp.io/

Hi folks,

Like others, I’m experiencing bug-like behavior when trying to set a column through a relation, as part of a button-initiated custom action.

This unexpected behavior doesn’t appear to replicate the other ‘set column’ threads I’ve seen; hence my post.

I’ve included a few screen shots (see attached).

The logic flow: Starting from a sheet called ‘reward chooser’ (this is context for the button action), I’m trying to set a Boolean column on a row that lives on a separate sheet called ‘Rewards’. That row in ‘Rewards’ is specified in a prior step in the custom action via a single value column random selection (whole row). Of note, ‘reward chooser’ is a single row sheet used for, among other things, that random selection.

As I set up the custom action, I given the option to refer to the target row in ‘Rewards’ either by a relation to ‘Rewards’, or by the single value column selection.

No matter how I set up the reference to the t

arget row, the custom action does not set the specified column in the target row. At this point, I’m starting to think this is a bug…

All constructive input welcome!

Thanks,
Mike

A clarification: the custom action workflow looks like this, with link to screen coming before the set column step:

Again, all good help & thoughts are appreciated!

Does it work if you move the set column module before the link to screen?

Thanks. No, I tried that too and no success.

It looks like you’re trying to set the column of a Single Value. I don’t know if that will work as it’s going to pull in the related values, isn’t it?

I’ve had some issues with Booleans and actions. Try changing your set value to “true” just to see if it might work. Again, I’m just guessing as I don’t know for sure how things are set up and referenced.

Hi, thanks. Yes, I’m trying to set a column in a Single Value Column; however, that Single Value was pulled as a whole row. So, as I’m the specifying the Set Column action, I’m presented with the appropriate choice for the column to set (the boolean, ‘Viewed by Primo’). The problematic behavior is that despite making what looks like the correct specification, that action does not occur–the boolean value is never set.

And now for something really bizarre… I tried a prior suggestion of using Boolean’s with “TRUE” values rather than 1. And, I specified the column in the set column action by using the Single Value (whole row) rather than the relation. And…suddenly the logic seemed to work correctly. To test this further, I then logged out of the app and logged back in…without having changed anything else. And upon logging back in…the logic appears broken again.

Mysteries of the universe…I’m still left with a broken logic train. All good suggestions welcome!

Hmm booleans seem flaky with actions… some weird stuff for sure. As a workaround, try setting a different column type to 1 (or true). Does it need to be a Boolean column?

Could always use an IFTHEN afterwards to set the Boolean value if the issue is related to setting a Boolean via actions.

I think you may have ended up at the current bug that I’m assuming hasn’t been fixed yet. I would agree that setting the value as ‘true’ is the correct way instead of setting it to 1. But, I think the existing issue is that a value will get set through a relation, but it’s technically only stored locally and doesn’t truly migrate to the glide database. That’s why when you logged out and back in, it pulled down the database again from the server, but it didn’t actually contain the updated value. You may be OK, with what you currently have, but will have to wait until Glide fixes the bug.

Thanks all…

I am concluding this is an important, unfixed bug in Glide.
In sum: I’ve tried using a number column rather than a boolean column, as @shchc suggests–this initially led to success in setting a column through a relation (in custom action). However, upon logging out of app and logging back in (with no other app changes), that functionality was again lost. That suggests a mechanism like what @Jeff_Hager suggests–an inconsistency in the Glide back-end.

At present, without this capability, I’m unable to develop what I need on Glide…

As always, I roll with a dose of humble–so if I’ve missed something, I’m open to constructive input & education. All good suggestions welcome!

Thanks…!

I don’t know if you caught it in one of the other threads, but Mark had mentioned a fix by Friday (today). They are aware of the issue and working on it. It remains to be seen if a fix is published today.

Thanks Jeff,

I did see that other thread but wasn’t sure if it was applicable to my case. Glad to hear they’re on it, and thanks again for your own input. Step by step…

1 Like

Seeking information: where would I most likely hear / read about any bug corrections or feature updates…e.g, the resolution to this thread’s issue?

Thanks…

Hi Jeff,

I’m looking for some Glide / expert help to determine if I’m seeing a system bug or my own error for some strange behavior I’m observing with an app (“Discrepancy phone vs emulator for random selection and switches”). What’s best way for me to get some assistance? (I’ve already posted, without much response)…

Thanks so much!

I’m having this bug right now, really annoying one

Can you explain some more and show some screenshots of your actions and app screens? I’ve had really good luck setting column values through a relation. My latest project does it quite heavily.

2 Likes

It’s been working all okay until’s been working all okay until I combine it with form submission action. The data I set in the relation column still appears normally in the app, but it doesn’t write on my google sheet.

Here’s some photos

When I submit, it still appears normal on-screen view of DATA, or on screen
image

But when I see the row in google sheets, it’s still the same. Even when I see the sheet through Glide view of the sheets

Send help pls, I have spent hours trying different things, without any

Btw, it’s still working okay if it doesn’t do anything with form submission