Set Column action is not working with relations

Hi friends,

I think it’s a bug because I have tried several times and ways but try using a Set Column action with a relation (simple) is impossible.

No field/column is written if you create a button for it. Even, the button is shown in GDE but not in live mode when it is set up as a Set Column action.

Any idea @mark or @george_b?


Are you sure that the detail view in live mode is attached to a row? Do you have any filters or row owners that would prevent the screen from attaching to a row? I’m guessing the button isn’t showing because there is no row and because of that, the relation is empty.

1 Like

@gvalero It’s hard to tell anything from that single image. If what @Jeff_Hager suggested as the possible cause of the issue turns out to not be the case, then email with the support link and details on how to duplicate the issue.

1 Like

Jeff, I triple-checked this and the relation works fine and I have no filter set up. In GDE I can see how the relation works and how it gets the data. As you say, the button in live mode isn’t showed because the relation is empty but I don’t know why!

Let me create a new and simple APP demo in order to help @george_B to understand the issue or know if the problem is me!

I’ll be back folks


1 Like

I think I found my problem source!

I have had many internet connection problems these 3-4 days and GDE has tried to save and synchronize my APP many times with errors but at the end, some data or components work wrong with some weird functionality.

Just when I created a new one (smaller and simpler) to replicate my case, on my new APP everything worked fine.
Maybe my original APP has something corrupted by this.

Anyway, thanks Jeff and George for your time and help me.
Have a great day and happy 2021!

Se cuidan, feliz día!