Rich Text field displays in preview, but not in published version

I have some text fields in a table. They are getting displayed using a Rich Text Field inside a form container. They display fine when I am in the editor of Glide.

I published and can’t see the text fields (or figure out why) they are not being displayed?

I thought of things like font color, changed various colors. Tried to change the text type in the Glide table to Rich Text.

What am I doing wrong? Thanks! screen shots attached. Behaves the same way in published app or web browser.
Incorrect display missing the Anthony Richardson reference

Correctly showing Anthony Richardson text in the Glide app work/edit area.

Can you show whats inside the Rich Text?

Not sure what you mean when you say “inside” the Rich Text.

The Glide table has text data in it that says “Anthony Richardson pick 4.5”

I used a Rich Text field inside the Form Container with the intent to display that text to the user in the app.

at this point, I can’t get it to display in a published version. I see it only in the Glide app editor views.

In Glide edit dashboard

Glide table

Oh, typically people use Rich Text when there is some sort of HTML being used.

Have you tried using a normal text component?

Also, I see that its using a USC to display. Is the same person who entered Anthony Richardson the same person as trying to see the data? My guess is not if youre trying to display his name to other people. Try changing the Column Type to non User Specific and see if that fixes your problem.


thanks so much. It was the combination of using User Specific fields in my Glide tables. Changed that and then used text component in my form. All displaying as expected now.

1 Like

Glad that worked!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.