Custom data in Rich text field not displaying on iOS

Custom data in Rich text fields is not displaying in my form currently on iOS (latest version).

Just displays an empty space.

It does display correctly on desktop.

How custom is it? Strip it down to very basic Markdown. I have no idea why the changed the name to Rich text, it should be called Limited Markdown. Also do you have any HTML in it? If so that could be the issue.

There’s some simple HTML in there so I tried changing it to simple markup like so
#### Title
Got the same result

Will modify it when I’m back at my desk to contain raw text, test, and will report back with results. Thanks @George_B

Tested with raw text, same result. Shows a blank space in iOS

Dumb question, but app layout changes aren’t always updated in the app immediately. Have you made any changes to the rich text component lately? Have you force closed the app on your phone, or restarted the phone? Is your app public, so we can take a look?

I’ve created a new app to demonstrate. Click the “+” icon in the upper right corner of the initial screen to see what i’m talking about:

Edit: Actually this made me realize that the bug also exists on desktop (it just shows in the editor properly)

This is clearly a bug. We’ll fix it. Thank you for reporting!

1 Like

Not dumb questions at all, thanks for chiming in with ideas!

1 Like


This should be fixed now. You’ll have to go to Glide and change something about the app, then it’ll work.

Confirmed on my end @Mark. Thanks so much for the rapid response!