New web view in button component not working

hi Gliders,

I tested today the new option of web view in the button components and no matter which link i tried to use to rmbbedd i got an error.

did any of you tried it? did you succeed in embbedding something to glide (not in the insiders but on the production)


I didnโ€™t even noticed that we view was in prodโ€ฆ But any test I made on staging failed.

You have links that work on staging but donโ€™t work in production? Could you share a few?

see below 3 links which i manage to embed in the staging webview component:,7340,L-8,00.html

they are in the app:

none of them is working in the production,

i was even able to embed Zoom link but not make it actually work (I can share with you my discussion with David on this if you wish)

All three work for me:

Could you please share the production app where those arenโ€™t working?

very wierd. now all of them working.
I came to send you the app and tested before just to make sure the bug is still there and for some reason itโ€™s gone.
If it happens again Iโ€™ll send you in real time + images for you to see.

one question, I see that itโ€™s not sowing a mobile version but rather cut the embedded site. is there a way to make it show a mnobile version or at least tell the webview the aize to present?

The web embed will only attempt to use the mobile site on a real mobile device. This is due to boring technical reasons based around CSS dynamic sizing. The mobile site can also sometimes fail to load in an embed while the desktop site will be fine. Again this is up to the developer of the original site.

1 Like

thanks will check

Hi @Jason and @Mark,

another issue for you guys with the webview.
Iโ€™m trying to embed a payment page from israeli company (meshulam) which allow my users to purchase specific product. the page present well and allow entering details but seems the button to move to payment is not responding. when I embed this page on other places like google sites for example it works great.

see example of the page itself stand alone here:

see example for the embed page in google sites:

see example in glide that is not working pass the first page:

you can see all the examples in the glide app as well.

As you know Stripe is not working in IL and this is a way to allow payment in glide without leaving the app itself so it will bust the ability to allow payments methods in glide.
the use case is that after the payment the user goes back to the form and send his data while in parallel the approved payment sends mail which I use automation to read and send the data to the sheet to allow the user to do other things in the app which he paid for.

appreciate your help to understand why the embed page not responding in glide but work in other places like google sites and WIX well.


The failure is due to content security policies set on Glide. We will need to evaluate what the right way forward is to both enable more permissive iframes that can do more but also keep users safe. For now I would use a standard open link action.

1 Like

I see. This is bummer. No payment support in IL is limiting the ability to create apps for customers like stores or any other payment related app.

Thanks anyway.

I agree its a bummer :frowning:

Any chance youโ€™ll Iโ€™ll implement a solution to this in the nearby future?

I have the same thing. Those two links worked in staging and donโ€™t work in production::


could you please instruct me where to find and how to implement the webview component? Iโ€™ve browsed the list of components a well as tried to use the available buttons, however I simply canโ€™t find it.

Iโ€™d appreciate your help.



@Chris_Fieldswee it is not there

Hi @Krivo,

thanks for your response. Does it mean that this feature is not yet available? Iโ€™ve found its description in the guide hence Iโ€™m a bit confused.


The web view component itself is not available, but you can assign the web view action inside a button.

@Chris_Fieldswee maybe @JackVaughan will adjust the documentation in glide so people donโ€™t get confused? The signature component is found in documentation but is not present yet to use in the builder.

Thank you, @Krivo & @ThinhDinh. Iโ€™d appreciate it if you could navigate me to the article describing an assignment of the web action inside a button.