New Google Sheet not accessible in Create App "From Sheet" option

I’ve created a new google sheet and uploaded on my gDrive.
I’ve double checked I’m properly logged into the same Google Drive a/c the one I use to signup with Glide. In gDrive I can access/edit the sheet like usual

When I create a new Glide App “From Google Sheet”, it still lists only my old sheets. Doesn’t reflect my new sheet that I just uploaded onto gDrive. I’ve logged out/in from both gDrive & Glide to no avail.

Is this a bug or am I missing something?

Thanks for helping!

Any chance you haven’t added headers to any sheets? If you have, can you try duplicating it to see if the problem still occurs?

Thanks TD.

After a few refreshes and more logins/logouts from both gDrive & Glide it worked (sorry i forgot to update the thread at the time). Though it still doesn’t accept or sync with major changes in the excel sheet.

For eg: I added a new tab to my sheet - it doesn’t get reflected in Glide (Yes I refreshed multiple times)

But any new rows added to the first tab or cell values edited in existing rows do sync pretty much instantly. Sometimes I have to manually refresh but it works.

About headers: How do you explicitly define a row as headers?
I just have a top row with <Sr No/Product/Description/Category/Price/etc> with some 4 or 5 rows of dummy data in it.

This is my first time using Glide

Glide will recognize a sheet when you have headers in the first row. If you are expecting a new sheet to automatically show up in the app, that won’t happen after the very first time you create the app. You have to add the tabs manually through the Glide editor. You really wouldn’t want Glide to add tabs for you once you have a working app. That wouldn’t look good because you still have to add any new tabs or components.

How does Glide know that top row is headers? For Glide it’s just 4-5 total rows of text data.
Other than formatting (bold/colors) how does Glide know whether my top row is headers?

Is there an app-level setting somewhere which I can use to explicitly mark header rows? Using examples tutorials I just assumed that top row is considered headers

In Data Editor I only see “Add Columns” option. I don’t see where to Add Tabs


Headers are usually your top row. A sheet can only be synced to Glide once they had some data inside the sheet.

The first row is anyways recognized as a header row. If the entire sheet is empty, then Glide won’t see it. As long as you have at least one header in the first row, then Glide will see it as you can with with the sheet in the app.

Watch the last video here to see how to add new sheets as tabs on your app.

Yes, I was referencing these tutorials only in my first comment.

There seemed to be some sync issue with:
a) identifying new google sheet created itself. after a couple of tries somehow it picked up the sheet from gDrive and I have a barebones app.

b) new worksheets created in gDrive didn’t lead to automatically creating new tabs in Glide. I had to delete the app and rebuild it by rebasing it off the new sheets (now with two or more tabs) and only then it synced with new tabs.

Anyhoo I think it’s just some sync issue between Glide and gDrive. For now it’s working so I don’t want to stretch it any further. If there’s some feature to mark this issue closed (or solution found), let it be recorded as such.

Thanks Jeff and ThinhDinh

Glide will not add a tab from a sheet once you already have the app started. Same with new columns. You wouldn’t want that to happen anyway once you are further along in development. I have several sheets in my apps that hold data behind the scenes. I would never want a tab created automatically on my behalf. Glide will only create any tabs and components the best it can the first time you create a new app. From there it’s up to you to add new tabs or components. You don’t need to delete your app and start over.

My point is even when I explicitly go in Glide Tabs section and try to add a new tab, it doesn’t pickup the new worksheet from gSheet. Doesn’t display it in the dropdown list. It only picks up the tabs which were in existence at the time of creatiing new app. So if I then delete the app, and recreate it off the new sheet it works.
But tbh, I haven’t played around much more since I first posted. So for now let’s consider the issue closed. For now it’s ok and I will continue to work with how it’s setup.

Thanks for all your help


Hi - I’m new. I’m having a similar problem. I just started making an app, so when I wasn’t able to find my additional google sheets in the dropdown list, I just started a new app. But even then, my google sheets are not showing up, only the first couple of google sheets seem to be available. Any help would be appreciated! :slight_smile:

Is there any content in the new sheets? There needs to at least be headings for glide to recognize it. They can’t be completely empty.

1 Like

Thank you! I deleted the data in those, that must be it. Much appreciated!

1 Like