Glide does not display sheets from Google Drive

Hello,
when I try to create a new app from Google Sheets, I only get some of the sheets.
The one I want to create an app from is not displayed.
How can it be fixed?
I tried to log out and log in and to fake re-registering a lot of times for it and it still doesn’t recognize all the sheets.

Do the sheets that you want to use contain any data?
Glide won’t recognise any sheets that don’t have at least a header row.

Yes they do (:

You might want to check setting next to a tab and make sure it’s not accidently set to hide.

Thanks.

image

Please make sure the Sheet you want to choose is shared with the email you’re using to login with Glide. Is this the case?

I actually having issues with the step before this one, where I need to choose a spreadsheet from Google Drive…

Yes the sheet belongs to the email I logged in and registered with

The search does not bring that up as well? How much data do you have in that Sheet?

Nope…
And it’s 7 “sub-sheets”, each one containing about 150 filled cells