Nasty Issue (I Think) With User Signup Sync

Intro

As far as I can see, something has changed in relation to User Signup, that makes onboarding unworkable. I saw this in a new app and reported yesterday. Support have not confirmed anything as yet. Today I tried creating another new app from scratch and I see the identical issue. However it does not appear to be affecting existing apps.

Overview

The app in question is Public Pro and uses a “sign in” action on a button to allow a user to register for access to additional functionality. They hit the sign in button, enter their email and receive a PIN, all in the tried and tested fashion. Once the PIN is received in their email they return to the app to enter it. They then onboard as see some exclusive content.

Issue

However, with my recent apps, whilst they enter the PIN and a row immediately appears in the User Profile Google Sheet, that same row does not also appear in the GDE. There is a very significant delay, certainly many minutes. This means that user onboarding cannot progress because there is no row for the app to associate with the various components e.g name, photo etc. If I re-sync from the GDE then the row appears immediately and the app becomes usable.

Here is a video link that demonstrates the issue:

Click For Vimeo

Observation

At the same time I have noticed very long delays before PIN numbers are delivered, again only with recent apps and not established ones.

Conclusion

I have existing live apps with customers that are using the same mechanism but do not seem to exhibit the issue thankfully. The new user row appears almost instantaneously in the Google Sheet and the GDE. However I am concerned that (a) they may start to exhibit if I modify them and (b) I cannot get my new demo apps out to potential customers.

Anybody else seeing this too?

7 Likes

:scream:

2 Likes

Happy Glideniversay @Darren_Murphy

2 Likes

This hasn’t been happening to me, but I’ve been having problems with row owners in the GDE.

@david @Mark I have not heard anything back from support and this is really hurting now as I can’t demo 2x apps to clients. Can you please let me know if there has been any progress in resolving or anything that I need to do at my end? Thanks.

Please create another support request via support@glideapps.com for this issue. I do remember working this issue, and believe it was sent on to Engineering. I’m unable to find the case or it’s disposition however, because I can’t link the open support case we do have with your info here in the forum. When I search V88_Google I get no hits.

Thanks,
George

2 Likes

I have the same problem.

I have now spoken with Glide in depth and they are able to reproduce the issue. It’s therefore likely that a resolution will be available in the short-term. I am supposed to be providing a “trial” to a customer tomorrow … hang in there and watch this space, they are usually very good.

3 Likes

In fact it “may” already be fixed. I am testing as we speak…

Try now. I think it’s fixed. Let me know.

Sorry. It’s not working again. It did on one device but then not on another. @david and @Mark just FYI issue persists.

We are having trouble reliably reproducing this issue.

3 Likes

Ok. Thanks for coming back. Please keep me in the loop since I am keen to deploy a solution once you’re happy.

Also, if this helps, in testing this afternoon we are seeing occasions when “normal” row updates are also being delayed significantly. Perhaps 1 in 20 times.

I cannot get user profiles to work, at all. When second user tries to come in, they get all the first row info in onboarding form. Using Robert’s Complete Profile approach, the Profile Complete gets incremented every time (got up 20), the onboarding screen doesn’t go away. I’ve been thru his video (#1) dozens of times, created app from scratch, ensure it’s all set up properly. Nothing. I have to present to client on Monday, and not having usable user profiles is deal killer

You will need to turn on Row Owners or filter by signed in user for the onboarding tab to work properly and attach to the correct user row.

1 Like

I had done that. Went back & disabled then enabled and it seems to be working. Ghosts lol

1 Like

Hi @david - I have just built out an app for a customer that uses this technique and the problem has recurred again. Not too sure where to go from here? Can you guys help?