Installed App opens in full screen (desktop/tablet mode), even though it is disabled in settings

Desktop mode is loading on desktop even though it is disabled in the settings. It is also blowing everything up HUGE - this is one inline list of cards and they take up the entire screen (have seen this happen before). URL:

In my other app it is enabled and is displaying properly.

1 Like

@Mark can you please fix this? I am advertising this app for early sign up on LinkedIn…people on Linkedin are mostly on their desktops. One clue for your team…this app was installed at a point when I DID have the box to enable desktop mode, and later unchecked it. In a new desktop browser it is displaying in phone view with no "show fullscreen option, and in new installs it displays properly. Nevertheless this is an edge case that should not occur. Glide needs to toggle the display setting in apps already installed to the current setting, even if changed after an app is installed. Let me know if you need any additional info. Plus, why is everything so huge? one inline list can’t take up the entire screen on a 15" Macbook. I want to re-enable full screen but not until I know this is resolved. I have seen this happen before and would like to know why it keeps happening and how it can be resolved by Glide so we can feel assured that the desktop experience is reliable-pretty much ALL of my app users use desktop at least some of the time. Thanks! @Jason

Update: This app when installed new (as of today), installed on desktop and tablet and opens in full screen mode even though it is disabled. Please fix this asap - Have already been waiting 17 days for a fix. I need to launch my app and need to resolve this asap first. Thanks! :upside_down_face:


Seems like a cache issue. Clear history/cache on the device and see if it’s resolved.

It’s not. This was installed on a new device.

Hmm then maybe the cache issue is on the Glide end. It may resolve itself after a few hours or a few refreshes…? Maybe some new data needs to be added so that it refreshes itself.

Since it has been 17 days, I don’t think it’s going to resolve itself. In any event, we can’t expect people to keep clearing their caches to get things to work/display properly. This is a far too common excuse. There must be a way for Glide to override cached data for certain key events (like toggling this switch). This has, however, been disabled for at least 20 days.

Whoops missed the 17 days part of your post. I agree, there should be a way to do this.


Happy Glideversary by the way! :star_struck: :partying_face: :relaxed:



I just want to clarify (apparently my notes were not filtering through support). /full links will always present a full screen app experience. This is needed for certain devices. Tablet layout is referencing the two pane mode Glide can enter. Not all apps will want this. There is no way to completely disable /full links at the moment. I have added it as a feature request.


1 Like

@Jason, however the problem is that I did not type in full. I scanned the QR code and it opened and installed that way. It’s a problem…it’s one thing that full can’t be disabled, but another problem that the QR opens it in full when you have it disabled in settings. Can you fix that ASAP please? Why should the QR open it in full when it’s disabled?

Also, it’s extremely misleading to give us a checkbox to disable full screen and then tell us that it works anyway. I think you should prioritize this if possible…

OH!!! Are you scanning with an iPad and expecting to get the phone preview?

1 Like

Yes, since full is disabled, that should be the case. FURTHER, this is how it behaved in the past, then suddenly I start getting full screen. Importantly, this does NOT happen when you open in browser, it happens with installed app. These things need to work consistently and behave predictably - as intended. Not phone view in browser and then full screen installed - when box is disabled for full screen…

Yup I agree let me work with the design team and see what we figure out that will work for everyone. I suspect your request is the ideal solution for tablets. Im sorry I was testing on desktop and super confused.

1 Like

Thanks, it has been weeks that I’ve been waiting for response/fix and trying to get this into QA for the app store, plus spending marketing dollars so I really need it fixed quickly please.

Also, even if you can’t turn off full, why does one inline list item take up more than the entire screen (installed app) on a 15" macbook pro? This is all in the thread above (please review)…

The INSTALLED apps are the problem…