Resolved | Tablet & Desktop Mysteriously and Randomly Getting Unchecked in Settings

Happy Sunday! Testing on all devices today! :blush:

Tablet mode was working great until a few days ago. Please see this short >2min video. Screenshot with iPad specs below as well.

UPDATE: I now find that Pro App installed on Desktop does not display in full mode. Exact same issue. Only thing that has changed for my app is that I hosted it on custom URL a couple of days ago and this issues seems to coincide with that change but could be coincidental. Please advise ahead of my launch which was slated for Monday - I will have to push it back if this isn’t fixed. Maybe I am missing something simple?

1 Like

I can’t test this issue and I’ve never used the full screen mode in any of my apps, but just thinking of ways to figure out the issue… Try duplicating the app and try accessing it through the new link that gets generated… Is it still not working at the new link? If it’s working fine, then it’s something with the custom domain. If I had to guess, it might take a little while for the custom domain to get all the configurations straight, or maybe some caches need to be cleared on the browser side of things.

1 Like

I will let Glide team figure out why because I’ve got a bunch of stuff to sort before my launch. I did uninstall and reinstall and still no luck - @Mark can you help or get this to someone who can help. I’ve sold this app to client that will use it equally on desktop as email so it’s important. Thank you!!! :pray: :pray: :pray:

This is one main advertisement image for my Saas subscription app for companies–important key feature is use on all devices so this has to work for my customer day 1. As you can see it was working when I took these screenshots and when I did a demo for the first customer! :upside_down_face:

2 Likes

Have you tried clearing browser cache?

1 Like

yup, when I uninstalled, it also asked me if I want to remove it from Chrome cache and I selected yes. I also installed on another laptap that I have never used to either login to the Glide Designer OR visited the site before or after custom domain, nor have I ever installed it there. I also checked a free app I have on glide domain and same issue.

Hmm I’m out of ideas! Must be a bug!

1 Like

Hi @Deena. I have two apps deployed for customers ATM. Both are PRO and both use tablet mode. I have just checked both and they are workign fine. I even reinstalled them to see if a fresh install would cause the issue, but still good. Sorry I can’t be of furtehr help. PS. My customers are using iPad and latest iOS 13 release.

1 Like

Okay guys -I’m obviously a nervous idiot ahead of my first customer onboarding–missing the most simple things. When I hosted the app, the “allow opening on tablet/desktop mode” was unchecked. I know for a fact it WAS checked/enabled as I took screenshots on desktop and tablet, so it must have gotten reset. I apologize for the fire drill. I’ve asked Glide team to see if they can arrange for settings not to be disturbed to avoid unnecessary drama on the part of dummies like me in future! haha. Thank you and truly SORRY for time anyone has wasted trying to help me with this!!! :smiling_face_with_three_hearts:

So lesson learned here along with some info from Glide support. My app is Pro but may have gotten caught in the transition of disabling the tablet/desktop mode on FREE apps - which ended on July 31. If you use this on your apps, take note and check on the setting. AND if you host your app on a custom domain, go back and check ALL your settings because this one gets reset. My little fire drill will hopefully prevent others! :kissing_closed_eyes:

2 Likes

No worries and glad you’re good to go!

1 Like

Okay, so this IS a bug. I had a customer sandbox demo my app this morning and could not access fullscreen. As you may know, after hours of being perplexed yesterday, I discovered the box was unchecked at some point without any action on my part–so I checked it off again yesterday and desktop/tablet worked immediately. This morning prospective customer can’t make fullscreen work and I find the box mysteriously unchecked again. @Jason @Mark this is causing some drama - users are already not tech savvy enough to quickly install to desktop and now when they do manage, there is further drama and I cannot possibly keep monitoring whether that box has been unchecked. I have also emailed support but please see if you can get this faulty reset issue fixed for those of us for whom desktop is critical to the user experience. My app hosted on www.gosupr.com if you need the url. Thanks! :pray: :innocent: :smiling_face_with_three_hearts:

Update: The AMAZING Glide team, as usual–chatted with me offline right away, immediately found the bug and is working on deploying the fix asap (targeting next 24-48 hours). Thank you! :pray: :kissing_closed_eyes: :star_struck: :blush:

3 Likes

Fixed by Glide just now.

3 Likes