Glide API continues to cause issues (200 POST requests) not appearing in data editor

Describe the bug:
I am following on from a previous post I made describing issues with making calls to the Glide Tables API:

In the above example I made an API call via make.com to update a row in my table. Despite getting a 200 response, the changes would (often) not be reflected in the data editor or the app.

Today, I tried to post a row to my Glide Table using Airtable Scripts and despite receiving a 200 response, the row is not appearing in my data editor at all.

CleanShot 2023-10-09 at 10.14.46

In the API call above I am only populating one field with a test value, so this is not related to user-specific fields or any special field types. It simply creating a new row with one text field that is populated with a string.

Expected behavior:
A new row should be created when the API call is made.

1 Like

Follow up on this:

I just noticed the following in my Airtable base: Each time a new record was created via the API call it did appear directly in Airtable BUT NOT in the Glide Editor, which makes me think the following:

You make the API call → goes directly to Airtable, instead of API Call → Glide Data Editor → Airtable

Can someone confirm if this is how the API works? @david

Best,
Connor

Are you adding rows to a Big Table by any chance?

If yes, you wont see the new row in the Data Editor until you reload the table.

No, that’s definitely not how the API works. Rows are added to the Glide backend, and then they sync with any secondary data sources (including the Data Editor).

Hi,

No I am not adding it to a Big Table. I am adding it to a table where the data source is Airtable.

Further on your comment:
Currently when I make the API call I see the record appear in Airtable all the time, but not in Glide. Eventually once the data source syncs from Airtable to Glide it appears, but it appears to not been added to the Glide Editor at the time of the API call happening.

This is a consistent bug and easy to replicate.

I can cross check it in the moment of the API call by seeing how many rows I have in that Airtable table vs how many rows I have in my Glide editor for the same table.

I always have less rows in Glide.

oh, yes… of course it’s not a Big Table if it’s connected to Airtable - duh :man_facepalming:

Okay, I guess this must be something specific to Airtable, which I’m not familiar with at all.
But regardless, I stand by the below statement:

It can’t be any other way, and I would be shocked to learn that it is.

Have you actually submitted a support ticket for this?
If you haven’t, you should. That’s the quickest way to get Glide Engineering eyes on the issue.
I’ll be interested to learn what the resolution is. I have to believe that it’s not typical. I use the Glide API extensively, and whilst there will sometimes be a short delay before new rows show up in the Data Editor, I’ve never seen an instance where they don’t arrive at all.

1 Like

I just had a similar issue using Zapier to update a row value using “set-columns-in-row” directly to a Glide Table instead of adding a row. I’ll be opening a ticket later this afternoon and let you know what I find.

1 Like

Submitted a ticket now!

Thanks for your help Darren.

1 Like

Glide support was able to find the problem with my issue. They didn’t provide any specifics, but I’m happy to know that it wasn’t something I did. :crazy_face:

Hi there, I have been experiencing a similar issue using make.com. Sometimes, only 1 column out of 2 will be edited (edit row via API), despite getting a 200 response and checking that both values are passed correctly in the request.
Any one else having this issue?

Hey there, I’ve you had any updates on your ticket ? I run through the same issue.

I’m having the same issue. I’m making the request from Make and its giving me a 200 but the row in Glide isnt updating the values. Intermittently works which is even more frustrating to be honest.