Form number input decimal separator

My g.sheets locale is correctly set, but when I try to input a decimal number in Glide app it only allows a dot, and not a comma. My locale uses comma, and sheets displays a comma as well. If I try to use comma in Glide input field, nothing gets passed to sheets, dot works, and it gets passed as comma to sheets.
Also in Glide data sources I see a comma if I did not edit the column, but as soon as I edit it (add units for example) I get dots instead of a comma.
Any advice is appreciated. Tnx.

Is the Locale for your browser and OS set correctly?

Language in FF is set to GB, there is no locale option. Locale in sheets is set to Croatian, and the language in Android is set to US, but the region is Croatia. Everything else works as expected.

I’ve seen 3 posts in the past few days regarding the locale for numbers, so I’m starting to wonder if there is a bug somewhere. It should be automatic based on your system settings.

This is for both Windows and android. The behavior is the same.

Hi Jeff, tnx for the reply. If you work for Glide and need to me to troubleshoot anything do let me know. Can’t today, way to exhausted, but I can try tomorrow.

I do not work for Glide, but you can try submitting a support ticket.

hi @Spiro,

maybe this helps. i assume it’s not a bug, it’s only that glide uses the US locale and this doesn’t seem to adjust in browser.

I got this hint from a glider today:

Hope this helps.

You should not have to do any special javascript to get the number formatted the way you want. Glide should be handling this depending on your locale. While the javascript solution may work, I don’t believe it should be necessary. Glide has been handling the decimal and thousands separator correctly for several years. Only recently, does it appear to be an issue.

The locale is determined by the device, and the app should adapt accordingly. If everything is working correctly, we can both view the same app and I will see numbers in US format, whereas you will see them in German format. Glide is designed to automatically handle different number formats, as well as automatic translation of certain components. The experience for each user should be unique to their device settings.


Interesting. As far as i remember Airtable had always problems with that topic.
So, we should then open a ticket for that.

I would recommend a ticket, unless others from your region can chime in. I tried it just now, and when I change the default language of my browser to German, it changes how it’s viewed in the table. OS Region setting didn’t seem to make a difference, but the browser definitely did.

Browser language set to English:

Browser language set to German:

I didn’t have to do anything special other than make sure my browser is set correctly…so for me it’s working as expected.


I can confirm this.


Also, please remember that the Glide number entry will accept any character in iOS Safari, be aware of that. Multiple users, including me, have reported this severe bug, but Glide does not care to answer for years.
Doing some crucial Apps, like accounting or inventory management, might cost you fundamental errors, and it is hard to find if you have extensive data. I would recommend fixing the entry to the number using JavaScript or creating a warning and rejection algorithm.

Hi all, tnx for the replies.
I can confirm that changing the language of my BROWSER does change the behavior. OS region does not affect the app. This does not seem right to me. I want my browser in English (and my OS), but my locale (region) in Croatian. This works perfectly with other apps/pages. Also what is strange is that when my app DISPLAYS the numbers, they are formatted correctly. Only on the input field of the form it accepts what is set by the language of the browser.
Is there any way to change this?

1 Like

Another thing I just noticed. Even if I change my browser language all my data sources are still “stuck” with a dot instead of a comma, and in the app data is displayed sometimes with a comma, and sometimes with a dot.
This looks more and more like a bug.

1 Like

…and I can’t open a support ticket as I just get sent to a page with a bot that gives me wrong info and when I ask to open a support ticket it redirects me back to itself…frustrating.

This is with browser set to Croatian, and trying to edit in Data sources. Data is displayed with a dot and upon edit it is with a comma. And app displays comma for some fields, and dot for others:
Screenshot 2023-04-05 093747

Oh… for years. Doesn’t sound good.
Maybe @Jeff_Hager, you as an expert and a really helpful ressource for glide AND new users get any response from them?
BTW: You are the reason, why i kept on working with this tool although is not that intuitive like Softr and Co.