Really no solution for thousand separator?

Hi guys,

if i have used a glide table with a number column is there really no option to format the thousand separator with a “.” instead of “,”.? In Germany these numbers have a complete different meaning. Maybe by using the math column in a smart way?

Thanks, Sabine

(Already checked all format options in google sheet or airtable and imported it;-(

@pluzgi I trust that your numbers are in columns set to numeric types?

@nathanaelb would you have any thoughts on this or what other settings need to be adjusted in the browser or on the device?
For further reference:

1 Like

@Jeff_Hager, yes the columns are defined as number type.

You can use a Java column and format your numbers to German:

return p1.toLocaleString('de-DE')

for display purposes only

1 Like

Hi @Uzo ,
Amazing, thanks!
If you sometimes come to a solution where this can be used for calculation too please send me a note.
Have a wonderful day.

1 Like

… hmm… just keep both numbers :wink:

Yep, for big numbers it works, but unfortunately you can’t use this approach for graphs and legends like this because the the formatted numbers/computed column doesn’t relate to the graph.

hmmm… yep, not good for that.

But there is a solution to that! LOL

1 Like

Great, how did you reach that?
I’ll send a :cookie: for an answer.:wink:

Hhahahahaha… pizza? I like German Beer :wink:

beer button

  1. Create a template column with the name and amount from the Java column plus € character.
  2. Uncheck the show values in legend box.
  3. Put the template in Labels.
  4. Put the regular number in Values.

It was a cookie :joy:
But for that you’ll get :beer:
I’m really happy now - looks like that now:

Thanks a lot, @Uzo!

1 Like

Na zdrowie!

@Uzo, if you don’t mind… I’ll have to use your flow today;-)
There is another separator challenge for the standard graph.
Do you have an idea for that too? Here i can’t uncheck the legend values.;-(

Thanks in advance.

There is no control over this chart values look.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.