Error saving date in "Column is user-specific"


I am making an app ( ) that contains 3 toggles (boolean) and 3 dates to be entered by the user, the columns are created with their type and the user-specific column settings.

The toggle save the state without problems, but the dates… sometimes they are saved, other times they are erased, sometimes they are erased when opening the object … I can’t get it to work so that each user can save their own dates.


Any ideas?

Many thanks


Hello Eduardo.

What are your visibility settings for those “Fecha” fields?

Hello ThinhDinh,

Show component when the toggle is true, but it doesn’t work either, even removing this condition.

Probably this, but might be another problem I’m not really sure.

I experienced this ping pong effect when I have a lot of choice and toggles in my screen.

Thanks ThinhDinh, it seems I have just that problem. “Ping pong effect”, I will wait for a solution for it, thanks for the attention.

1 Like

Glide team said they will fix it soon, so fingers crossed.

Have a nice week, and stay safe!

1 Like

Not sure if you changed anything since you posted this, but I was unable to get the date entry to show up at all. The switches seemed to work fine from what I could see. I tried to get the ping pong effect to show up. I’d be curious to see the settings and the visibility settings for the date components if you still have them in your app.

1 Like

Hello Jeff,

I had hidden options so that it only appeared to me, the option to enter the date should work for you.

This is the visibility settings for the date fields:
Día 1 is the toggle

Thank you very much for your interest.

I tried out your app a little bit yesterday and today. This is definitely weird. I was able to add dates, then they would all clear out. I let it sit for a bit, but they would only refill with my previously selected values when I refreshed the app.

First enter date:

A few seconds later, they wipe out:

Waited 5 minutes for a possible refresh. Still no change.

It wasn’t until I refreshed the browser window that I was able to come back in and see the dates:

I’ve never used a date entry for anything other that within a form, but this definitely seems like a bug or part of the ping pong effect. I’m guessing it may be related to the date possibly being reformatted to a friendly view. Are you setting the date column to have a different date display? I suppose you are since you can’t avoid it with a user specific column.

I choose date only, it is not necessary for me to save the time


This will be fixed soon.

1 Like

Thank you very much for the interest Mark