Ping Pong Effect

Hello @Mark, any news about this bug? I’m getting this on all my apps

Could you please share your app and tell me how to reproduce it? Can you make a video?

I can’t share my app but I already made a video:

In the video you can see two choice components (user specific), and in the moment I press the button you can see in the form that one of the values has changed from what the choice component said.

It happens in detail screens with choice components, check box, switch, it is aleatory

@gvalero I think you have an example right?

1 Like

I’m sorry, I have a hard time following what’s happening there.

Could you share the app in a PM and tell me the steps to reproduce this, please?

I’m so sorry Mark it appears that the bug has been fixed already, I have made a new app just to explain this to you but the bug isn’t there anymore. I’ve made this example app:

https://pingpongeffect.glideapp.io/

When the ping pong effect occurs everytime you change a value on any of those components the value in te other changes, but now is not happening anymore.

In June you told us you were working on fixed it:

I can swear the ping pong effect was a real issue. @gvalero can say that aswell

Sorry for the problems and thank you for your help

We shipped the fix today.

When did you last observe it?

5 Likes

I have observed it a couple of days ago. I’m so glad that you have fixed it, it is great news.

Thank you very much

2 Likes

Great job @Mark!

I have tested 3 of my APPs with this problem and now everything works perfect. On last sunday this problem was still alive.

Thanks for the post and good news @AlfredoZGC.

Saludos

2 Likes

It was mostly @Daniel_Sweet who did it.

5 Likes

@Mark the bug is back again!

@Lucas_Pires Could you show us a video, please, and give us a support link to your app?

@mark, I guess was a temp bug! Thanks

@Mark it seems that this bug is back in action.

I think @Darren_Murphy could confirm.

Has anybody else had this problem again?

In order for us to look into the issue please create a support case by emailing support@glideapps.com. It’s best to create a small sample app that isolates and demonstrates the problem. Make sure to include the following information:

  1. A support link (if it’s a sample app and you make it copyable then just the URL of the sample app will be fine.)
  2. Directions on how to navigate to the area with the issue.
  3. Who the logged in user should be, if applicable.
  4. A description of the issue, or even better, a screen recording (narrated if possible) showing what you are experiencing. You can use loom.com or equivalent.

Thanks,
George

2 Likes

yeah, I’m not really sure. I’ve definitely seen “flip-flopping” behaviour - it usually seems to happen when you’re clearing multiple User Specific Columns, and then doing a Link to Screen as part of the same multi-step action. This was an extreme example though, as we had about 70 User Specific Columns involved. But it’s moot now, as we ended up taking a completely different approach - which resulted in just a handful of User Specific Columns :rofl:

3 Likes

Interesting today.

Had a simple action ‘set row’ in another table via a relation from a submit on a form.

The action performed as expected.

About an hour later the data, in the rows changed via the ‘set row’, reverted back to the original data entered.

Thinking it was a one off I recreated the action and again and performed the ‘set row’ it worked as expected.

2 hours later, guess what, it reverted back to the previous data.

Given up for tonight, after all it is Sunday. :thinking:

Assume you have reported to glide support as instructed by @George-Glide ?

3 Likes

As @Darren_Murphy mentioned we decided to take another route. So, no I didn’t.

1 Like

Ahh ok… hope you got it sorted. Definitely something up. Ping ponging is still a thing :face_with_raised_eyebrow:

Off to bed now so will check it again in the morning.

1 Like