Display of database

What’s up, everyone,
The problem is I can’t display information from a database onto a screen of my app.
I attached two screens here. Let’s look at “New column A” of the database.
I attempted to show this column on a screen but it does not work.
Could you pay attention to this case? I would appreciate it.
Thanks for reading.

So you added a component on the screen that points to that IF column? Can you show a screenshot of the component added to the screen and the configuration for that component?

Hello, Jeff Hager,
sure, here you are.

I would like to display any of these columns (Relation, LookUp, New Column A).
It seems I’m not able to display any information when it comes to not basic columns.

Do you have any filters on your screen, or row owners set on any columns in the data?

No filters and I’ve just deleted a Row ID. It didn’t help.

Not the RowID column. That has nothing to do with row owners. Do you have Row Owners set on any of your columns? You can tell if you’ve set row owners on a column because it will usually have a little blue avatar icon (something like this👤) next to the column header.

Oh, I got you. It still doesn’t work.

So you don’t have row owners applied to your data? That screen shot show that you changed to view any anyone. Row owners are applied to a row in the data.
Switching to preview as anyone doesn’t prevent row owners from taking affect if you have them applied. If it’s deemed that you are not the owner of the row, then that row of data will not be available in the app. I just want to be sure that you haven’t applied row owners to a column that doesn’t contain an email, or to a column that doesn’t contain the email of the user you are previewing as.

1 Like

I understand what you mean. To make sure, I set a row owner.
I flipped through docs Row Owners. Do we understand each other?

No, I want to make sure that you do NOT have row owners. You’ve applied row owners to a column that contains a name. Row Owners only work with columns that contain emails. The email has to match that of the user that is signed in to the app or the user that you are previewing app as. The way you have it set up now will guarantee that you will never see any row data in your app. I’m not asking you to change anything. I’m only asking questions so I can determine how you currently have your app set up so we determine what may be the problem.

It’s late, so I’m going to call it a night, but I would also try refreshing the browser, restarting the browser, and if neither of those make a difference, then consider clearing your browser cache.


I’m about and have been following the thread. I’ll do what I can to help him get it sorted.


Anyway, thanks for your time, Jeff!

What’s up, Darren)
Any suggestions? What’s the issue can be?

Have you removed that Row Owner setting on the name column, as Jeff suggested?

Also, what do you see when you select the “Data” view in the layout screen?

Can you screenshot that and show me?

Yeah, I’ve removed it. I have a suggestion, would you mind if I share this app with you?
It would be more productive.

Yes, okay.

You know how to publish it and make it copyable?

Get it?

Yes, I’ll have a look.


The problem you have here is in the way that you are handling the dates.
Give me a little while, and I’ll fix that for you.

Oh, thanks a lot, Darren!
I would appreciate it!