Disabling favorites module

Hello,

I have activated favorite module on my project.
But I decided to remove it now.
I have removed all favorite instances from the designer area.
I also removed “is favorite” column in data editor.

But, I’m still getting favorites bar on top of my inline lists.

Am I missing something?
Anybody had that issue before ?

Many Thanks

What’s the layout you used for the tab? If you have an inline list that’s a details layout and the favorite section should not be there.

I’m using details layout on all my tabs.
I checked every single inline list, couldn’t find
And there is no “is favorite” column in my sheet now.
Still, I’m getting all/favourites bar at the top

url : spasoul.net

How can I reproduce the problem? I don’t see a favorites module in your app.

I can see the fav Segment control as below screenshot. Can you share the screenshot of your designer for this layout? Or if possible can create a duplicate of this app and share with us.

Hello,
The screenshot is below

@zeki Just check the below setting as well (scroll at the bottom). I just tried in my app and it gets removed. The Button has the Favourite setting.

Screenshot 2020-07-31 at 12.18.59 PM

Yes, but there is no favorite overlay option in map layout.

Yup… i can see Map Layout doesn’t have Fav Overlay… Quite Strange…
I just created the same design and saw a Fav Segment when enabled the Fav Button on the detail screen but it got removed as i remove the fav.
There is somewhere in the app fav enabled which is causing it shown here by some linking
Is it possible to give a sample or access to your app?

But there is no “is_favorites” column on the sheet
I think, it’s kind of bug or glitch

Possible.

I deleted one of my relation link and create it again.
It’s fixed.

Thanks so much for the help

2 Likes

This is a bug in how we handle favorites. I’m glad you worked around it. It seems we retain some settings even if they are not currently in use which tricks Glide into thinking that favorites is in use.

1 Like

Hello Jason
I thought the same that’s why I removed the linked relations and it worked after.
I’m sure it will be fixed very soon.