Favorites shows with no favorite button anywhere

Does anyone know why, in a tab with cards/lists/tiles layouts, the ALL/FAVORITES shows up - even though I have no favorite button anywhere on the tab, or in the details page components? Even unchecking search bar leaves the favorites - and I actually want the search bar but not the favorites - it makes no sense for it to show when there isn’t a way to mark something as a favorite. Yes, I understand that I can switch to details view to get rid of it, but I don’t want to use details view. :upside_down_face: Probably I’m missing something simple…


Based on the posts I read, it’s a bug that never got fixed.
If I remember it correctly, I fixed it by this way - Upon creation of tab, go to details view and then switch to the list, tiles, or cards view. This removes the all/favorite bar but keeps the search bar.

Hope it helps.


Yup, but I specifically do not want the details view because I want the ADD option. I will report as bug or follow up on the bug report if I find one.

1 Like

Let’s wait and see what other have to say. We could be wrong.

Thanks for reporting it in advance.

Ah, but there isn’t anything to say (but will stand corrected if I’m wrong) - it’s a bug! You can’t show the user a tab to switch to favorites if they have no way to mark anything as a favorite. The other threads about the variance between using form buttons vs. the ADD function are also creating problems in providing a consistent, flawless UX. When you combine the two issues, it’s a multi-faceted problem that we run into frequently. :upside_down_face: Anyway, I’m sure Glide will get it sorted. They always do. :blush:

1 Like

You have a lot of Favorite button overlays in this app. Are you sure there is none that lets users favorite an item in that sheet?

1 Like

@Mark Welllll, I have an FAQ page that is a list from one sheet that appears only in one list…and that doesn’t possibly have any favorite option anywhere. In any event, if in a tab you don’t want it, it shouldn’t show up uninvited, even if you use a layout on a different tab where you do want it. :grin:


In the “All Seekrs” screen, if you go into the details screen, there’s an Inline List with Seekr Questions that has a Favorite button overlay.

In addition to that, and this looks like it’s a Glide bug, there’s a button overlay in the “default” list screen for Seekr Questions, but it seems you can’t even get there in the app (that’s why I think it’s a bug). You can remove the button overlay there by making a List Relation to Seekr Questions anywere. The screen that opens from that List Relation is the default list screen. Remove the button overlay there, then the Favorites switcher will go away (you might have to reload Glide because it might not rewrite your list screen automatically).

I know this is a pain, and we should fix it. Glide is trying to be too smart for its own good.


Yes, I do have some places where I have favorites as intended but not in the two examples I shared (Seekr Questions & FAQs). Thank you for the suggestion. I won’t do workarounds for bugs - well not with relations anyway! I don’t want to go and undo things later and I want to build a clean app. I did switch to details view for this tab to solve it for now, but please fix it! I know you guys are working on bigger bugs at the moment but hopefully this gets in the queue as it has been several months. :upside_down_face: :innocent: :pray:

1 Like

Actually, there is a way to get to the default list screen for Seekr Questions:

In the same “All Seekrs” detail screen, said Seekr Questions Inline List has a truncation option, so if the list is too long it’ll show the “See all” button, and that button leads to the default list screen. I know this is super odd and unintuitive. I hope we can fix it soon.

1 Like