Data changing on its own

My App/Pages Support link:

Describe the bug:
Data in data editor changing on its own

Expected Behaviour:
Add row with data from form (using multi step form page in app)

How to replicate:
Log into app
Go to New Page
Complete form
View data in data editor, it will change twice after row is added

Again after row 36 is added 37 and 38 are added and the data changes without any other action apart from viewing the data in the data editor.

This does not happen when using Multi-step form (Glide tables), only on New Page (Excel).

Hi @blairrorani

As we are unable to reproduce this issue, we have sent an invite for a diagnostic tool called Replay. Replay is a tool that records both the front end of your app as well as the back-end and what Glide is doing in the background. This will help engineers find exactly what the issue is faster.

We would like for you to:

  • log in to this tool
  • Open
  • Hit the record button on the upper right corner
  • Open your page
  • Fill up the form
  • Show the behavior on the grid

Note: Long recordings will not save properly, so keep the recording to under 1 minute in length.

After finishing the recording, please move it to the Replay team we have created for you and send us the shareable link for us to diagnose the issue.

1 Like


Here’s a link to the Replay recording.

1:20 Row 46 is added (not at the bottom of the other rows?) where name = Zorro
1:45 Rows 46, 47 are added, data that was in row 46 is now in row 49 (Zorro)


  • Using the Glide editor to add a record seems to work okay
  • Adding a record from the app doesn’t work

Also I tried again (just to make sure I could replicate every time) and it took too long to be included in a 1 min recording. But eventually the result was:

I know that isn’t super helpful but it’s hard to predict how Glide will act.

Managed to get a shorter
User is Replay2 Support Worker Portal for user Replay2

Tried creating a new Glide Page.

Added a record using the standard actions.
Viewed data source.
New row disappears (see Replay recording)

On this page I see this message:
Screen Shot 2022-09-08 at 8.31.53 am