User added data is added twice

My app’s URL:

Hi there GlideApps,
First of all: thanks for making this AWESOME no-code platform. I’m super impressed with the ability of creating an app based on a spreadsheet so quickly.

The issue I have is as follows:
What the app is supposed to do is:

  • user get access by having their emailaddress in users tab of Gsheet (we have enabled sign in with Google. We have upgraded to the pro version.)
  • users fill in simple fields and users add picture of a work-related document (with image picker)
  • users are able to view only their own data (this is done through row owner connected to e-mail addresses column)
  • backend users can view all data, so all rows regardless of row owner. and use this data by looking at the Gsheet

So first everything seems fine, but after some fiddling and testing and deleting some testing rows in Gsheets, an issue or bug appears.

  • user adds data
  • data shows up correctly in Gsheet
  • data shows up twice in ‘data’ tab in Glide editor
  • data shows up twice in user-app

I’ve already recreated the app in a new app. At first everything was fine, but after deleting some rows (I think) the issue popped up again.

Screenshot of data tab in glide:

Screenshot of Gsheet (not that the data is not double here):
New users can only post one image in topic, so I’ll post this image later…

Is this a bug that needs squashing or is this a config-error on our side?
Any help is greatly appreciated :slight_smile:

Screenshot of Gsheet not having the double data:

I noticed this too. I tried reproducing it by deleting the entire data on the sheet. Wasn’t able to reproduce it.

Does is correct itself if you refresh the browser or reload the sheet? You could also try adding a Row ID column in the data editor to see if that helps Glide to keep better track of data.

Thanks for your reply, Jeff_Hager! I’ve cleared the browser and app cache, reloaded the sheet and added the Row ID column (cool function btw, thanks!). However, no dice :frowning:

I still get the double rows (with matching row id, as well):

I’m not sure on this. Seeing that the Row ID’s are identical, there is definitely something buggy. Looks like there are a couple of other reports here. One where they simply duplicated the app to correct it:

I experience this in my own geo-radius test app.

I just logged in to create a new user profile, the Google Sheets only show 1 line.


While the data in Glide shows 2 lines.


It is making my inline list wrong, so I think this is a bug.

1 Like

Thanks @Jeff_Hager for being on top of this subject. This indeed seems like the same issue:
Unable to Delete Data from Glide, though not Showing in Sheet.

1 Like

Are there any updates on this issue? I have the same problem, row that was added by user (via forms) is showing twice in Glide datasheet and in app itself, but not in GSheet. When you create new record, old one is shown only once, but new is shown twice again.

@Jelle_de_Rijke @Jeff_Hager


That is strange if you have a mismatch between Sheets and Glide. Probably this is not the root cause, but do you have an add row action on submit?

1 Like

Does this happen in the published app, or only in the Glide editor?

1 Like

Closing due to inactivity. This topic will be deleted in a few weeks if there are no more comments.