App works on desktop but not on iPhone

I have created an app in Pages that is to be used by technicians to, after a new heating/air conditioning system has been installed, conduct Quality Control inspections. I’ve invited two users to use the app via email. I also sent a link to their iPhones.

Both report they can open (from the email link received) the desktop running in a browser. But after that session, they are not able to log in to the app without a pin, as it doesn’t seem to be an actual app on the iPhone or iPad. Are Pages-built apps not stand alone apps on the iPhone? Must they run in a browser? Finally, are there some sharing features I have not used properly in deploying the app? Both of these users are listed in my Users table.

Glide apps (PWA Progress Web Apps) can be installed, but they still run with the browser as the underlying engine. If they opened the app in Safari on theirs iPhone, then they should have been presented with an option to install it Regardless, you can install the app to the home screen, or you can still run the app by typing in the url for the app.

You probably sent them a magic link, which bypasses the sign in screen, But any time a user navigates to the app without a magic linkz then they have to sign in. There needs to be some way to authenticate the user. Either they use a one time use magic link, or they sign in. That’s how the app knows who is who.

Are your using signing out of the app each time?
Are you setting the authorization cookie so they they stay signed in?

1 Like

Thanks Jeff. I’ll try the cookie feature. Should I select both cookie options?

You can only choose one. Pick the one that makes sense to you.

-Either you set the authorization cookie so that a user signs in and stays signed in until they choose to sign out.
-Or, you give the user a choice if they want to set the authorization cookie. Then they are presented with a checkbox when they sign in. If they check it, then it will keep them signed in. If they choose not to check it, then they will have to sign in every time they use the app.

1 Like

I have created a new different app to use instead of the first one for timesheet entry. It is a mobile app. I have a Users table that has been designated as the User Profile table. In the Privacy Settings I have inadvertently toggled on the “Only My Team1 Editors” can sign in. I can’t deselect it.

What should I do?

Before doing that I had invited employees to use the app via email invitation. I tried getting the system to work with our first employee named Andy. He received a pin after responding the email invitation I was able to open the app and attempted to make a timesheet entry. There are only two fields of entry: Begin Date/Time and End Date/Time. The app automatically adds the user’s email and email address to the timesheet entry. It allowed him to enter the Begin/End Dates/Times, but when he pressed the Submit button, it came back with a simple red Error message. Nothing else.

I sent Andy a magic link and, upon entering his email address the response was “This email address doesn’t have access to this app. Please try another.” I can literally view his records when I view as Andy.

What am I missing?

Can you show us a screenshot of this?

Also, are you on a Classic App?

Yes this is a classic app. Glide is behind in getting my account moved over to the new platform.

Why do you say that you cannot deselect the Team Editors option? I don’t understand why you can’t. Can you share a screenshot of your privacy settings?

1 Like